View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 2 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Jul 17, 2010 10:30 pm 
Offline
Joined: Wed Nov 09, 2005 11:40 am
Posts: 22
I used the install_hulu.sh script to install the huludesktop (including copying the menu manually to the correct directory). It launches fine, but I get no sound. I tried launching it from a console rather than from the mythfrontend and here is the output I get in the console:

Code:
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib pcm_hw.c:1429:(_snd_pcm_hw_open) Invalid value for card


It looks like the huludesktop (or any other flash player for that matter) is trying to use ALSA to do the sound. I am not using ALSA as it doesn't work** with my sound card. I am using OSS instead. I get sound for everything else (vlc, frontend, xine, mplayer, etc...), just not the flash based stuff. Does anyone know how to force flash to use the OSS drivers instead? My google-fu has failed me and I'm getting extremely frustrated.

** my sound card is an on board and the system shows it as an MCP61 High Definition Audio. If anyone can tell me how to get that to work with ALSA, I can go that route as well. post edited to show the output of ossinfo:
Code:
Version info: OSS 4.1 (b 1051/200902180218) (0x00040100) GPL
Platform: Linux/i686 2.6.28-LinHES #1 SMP PREEMPT Sun Nov 1 06:47:02 UTC 2009 (Envy)

Number of audio devices:        8
Number of audio engines:        12
Number of mixer devices:        1


Device objects
 0: osscore0 OSS core services
 1: oss_hdaudio0 nVidia HD Audio interrupts=5577678 (33359280)
    HD Audio controller nVidia HD Audio
    Vendor ID    0x10de03f0
    Subvendor ID 0x14627309
     Codec  0: ALC883 (0x10ec0883/0x1462f603)
 2: oss_usb0 USB audio core services


Mixer devices
 0: High Definition Audio ALC883 (Mixer 0 of device object 1)

Audio devices
HD Audio play front               /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play rear                /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio play center/LFE          /dev/oss/oss_hdaudio0/pcm2  (device index 2)
HD Audio play side                /dev/oss/oss_hdaudio0/pcm3  (device index 3)
HD Audio play pcm4                /dev/oss/oss_hdaudio0/pcm4  (device index 4)
HD Audio play spdif-out           /dev/oss/oss_hdaudio0/spdout0  (device index 5)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin0  (device index 6)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin1  (device index 7)

_________________
\\ENVY - LinHES 7.2
Athlon 64 4000+
2GB RAM
nVidia GeForce 8400GS
Hauppauge 350
MCP61 High Definition Audio
300GB


Top
 Profile  
 
PostPosted: Mon Sep 13, 2010 5:05 pm 
Offline
Joined: Thu Sep 21, 2006 8:51 pm
Posts: 2
I was able to get Hulu Desktop sound working with OSS under 6.03 by installing libflashsupport.so.

From my LinHES box I grabbed this precomplied 32-bit binary:

Code:
wget http://www.fileupyours.com/view/77985/libflashsupport.so


Then installed the library:

Code:
sudo install -s libflashsupport.so /usr/lib/oss/lib
sudo install -s libflashsupport.so /usr/lib
sudo ldconfig


This page explains and also give instructions on how to compile the library for yourself:
http://www.opensound.com/wiki/index.php/Configuring_Applications_for_OSSv4#Adobe_Flash


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu