View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 16 posts ] 
Go to page 1, 2  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Nov 07, 2010 4:27 pm 
Offline
Joined: Sat May 12, 2007 2:41 am
Posts: 49
Location: Southern Germany
Finally made the switch and upgraded from R5.5 to 6.03 (via 6.01). Most things worked great out of the box or could be fixed, but here's one thing I can't get right:

In the "Watch recordings" screen some non-functional "buttons" appear above the list of recordings. See the image below.

Is this display normal? The buttons appear in all themes I tried. Any ideas how to fix this?

Image

Thanks for any help!

Jens


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 4:24 am 
Offline
Joined: Thu Dec 07, 2006 10:25 am
Posts: 109
Location: Elgin, Illinois
I have had similar problems with some of the themes. The problem I mostly see is that some columns are cut off, usually the date and time. Almost like the theme is not for a widescreen even if the name says it is.

Did you install the extra themes package? It is optional so may not have been installed by default. It won't fix this problem, but will give you more themes to try.

_________________
The Atomic Ant.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 11:33 am 
Offline
Joined: Sat May 12, 2007 2:41 am
Posts: 49
Location: Southern Germany
Made a test with every theme installed. Result:

Themes where display of the screen is okay:
    Blue Abstract
    Childish
    Graphite
    LCARS
    Metallurgy
    Retro
    TransBlue
    Arclight

Themes where screen is messed up similar to what is shown in the picture in post #1:
    blootube
    blootube-wide
    blootube-lite-wide
    LinHES
    neon-wide
    Project Grayhem
    Project Grayhem-wide
    Willie
    bando-blue


I have a 4:3 display, tried with QT and OpenGL painter and all menu styles available (standard, classic, PVR ...) on first screen of appearance settings.

Obviously it *is* theme-dependant, but I know some people using the blootube or LinHES theme do NOT have the problem. Or does it look like this for everybody using the themes listed here?

Thanks for your help!
jens


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 5:04 pm 
Offline
Joined: Sat May 12, 2007 2:41 am
Posts: 49
Location: Southern Germany
One thing I noticed: The number of .xml-files in the blootube-directory is significantly smaller than in some other themes.

In particular, there is no recordings-ui.xml file.

Is this true in other people's installations, as well?

If anybody could report the result of
Code:
ls -l /usr/share/mythtv/themes/blootube/*.xml

and
Code:
ls -l /usr/share/mythtv/themes/*/recordings-ui.xml

that might help in tracking down this issue.

Thanks!
Jens


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 8:11 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 522
I am using a widescreen display and while the "buttons", as you are referring to them, are at the top, they are not overlapping the programs as they are on your screen. I am using the blootube-wide theme. As far as I am aware, they are there to show what filter options you have selected. Mine are LiveTV, Default, and All.

My result of:
Code:
ls -l /usr/share/mythtv/themes/blootube/*.xml
Code:
-rw-r--r-- 1 root root   729 2010-04-25 22:53 /usr/share/mythtv/themes/blootube/base.xml
-rw-r--r-- 1 root root 24576 2010-04-25 22:53 /usr/share/mythtv/themes/blootube/menu-ui.xml
-rw-r--r-- 1 root root 25177 2010-04-25 22:53 /usr/share/mythtv/themes/blootube/music-ui.xml
-rw-r--r-- 1 root root   896 2010-04-25 22:53 /usr/share/mythtv/themes/blootube/themeinfo.xml
-rw-r--r-- 1 root root 87307 2010-04-25 22:53 /usr/share/mythtv/themes/blootube/ui.xml


Code:
ls -l /usr/share/mythtv/themes/*/recordings-ui.xml
Code:
-rw-r--r-- 1 root root 35376 2010-04-06 00:05 /usr/share/mythtv/themes/Arclight/recordings-ui.xml
-rw-r--r-- 1 root root 25042 2010-07-22 20:32 /usr/share/mythtv/themes/Childish/recordings-ui.xml
-rw-r--r-- 1 root root 40957 2010-04-06 00:05 /usr/share/mythtv/themes/Graphite/recordings-ui.xml
-rw-r--r-- 1 root root 37146 2010-02-22 15:09 /usr/share/mythtv/themes/LCARS/recordings-ui.xml
-rw-r--r-- 1 root root 38463 2010-04-06 00:05 /usr/share/mythtv/themes/MythCenter-wide/recordings-ui.xml
-rw-r--r-- 1 root root 23987 2010-08-14 18:59 /usr/share/mythtv/themes/MythCenter/recordings-ui.xml
-rw-r--r-- 1 root root 15386 2010-04-11 20:56 /usr/share/mythtv/themes/Retro-wide/recordings-ui.xml
-rw-r--r-- 1 root root 27414 2010-04-06 00:05 /usr/share/mythtv/themes/Terra/recordings-ui.xml
-rw-r--r-- 1 root root 22244 2010-02-22 15:09 /usr/share/mythtv/themes/TransBlue/recordings-ui.xml
-rw-r--r-- 1 root root 31505 2010-06-12 09:20 /usr/share/mythtv/themes/Willi/recordings-ui.xml
-rw-r--r-- 1 root root 36326 2010-03-11 11:05 /usr/share/mythtv/themes/bando-blue/recordings-ui.xml
-rw-r--r-- 1 root root 50737 2010-05-19 16:32 /usr/share/mythtv/themes/blue-abstract-wide/recordings-ui.xml
-rw-r--r-- 1 root root 17561 2010-04-06 00:05 /usr/share/mythtv/themes/default-wide/recordings-ui.xml
-rw-r--r-- 1 root root 22914 2010-04-06 00:05 /usr/share/mythtv/themes/default/recordings-ui.xml
-rw-r--r-- 1 root root 30777 2010-04-06 00:05 /usr/share/mythtv/themes/metallurgy/recordings-ui.xml


Hope this helps.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 9:04 pm 
Offline
Joined: Mon Dec 24, 2007 9:47 am
Posts: 535
Location: Ottawa, Canada
Theming changed quite a bit as of myth 0.23 which is what LinHes is based on.
heilig wrote:
Made a test with every theme installed. Result:

Themes where display of the screen is okay:

These themes were designed with 0.23 theming changes

heilig wrote:
Themes where screen is messed up similar to what is shown in the picture in post #1:

These are the older themes which were not converted.

I believe you can find the current theme support on the mythtv wiki at:
http://www.mythtv.org/wiki/Category:Themes


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 10:13 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1291
Location: Orlando FL
try messing with the font size in the settings->mythtv->general->apperance menu (i think that's where they are) the older themes used those font size settings the new themes like Blue Abstract ignore those font settings.

_________________
My System


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 22, 2010 11:09 am 
Offline
Joined: Mon Nov 22, 2010 10:20 am
Posts: 5
heilig wrote:
Made a test with every theme installed. Result:
I have a 4:3 display, tried with QT and OpenGL painter and all menu styles available (standard, classic, PVR ...) on first screen of appearance settings.

Obviously it *is* theme-dependant, but I know some people using the blootube or LinHES theme do NOT have the problem. Or does it look like this for everybody using the themes listed here?

I use a 4:3 display and am having the same problem with the themes you mentioned. For example, MythCenter is fine, but Project Grayhem has those overlapping buttons at the top, as shown in your screenshot.

Changing the font sizes as suggested by 'christ' did not seem to have any effect.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 22, 2010 10:00 pm 
Offline
Joined: Mon Dec 24, 2007 9:47 am
Posts: 535
Location: Ottawa, Canada
kokoa wrote:
Changing the font sizes as suggested by 'christ' did not seem to have any effect.

I believe mattbatt suggested that. I was suggesting you are using an unsupported theme. Is there any reason you would not use one of the supported 0.23 themes?


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 23, 2010 12:15 pm 
Offline
Joined: Mon Nov 22, 2010 10:20 am
Posts: 5
Oh, sorry, that was mattbatt's suggestion.

I've been using MythCenter for a while and it's really nice, but I'm a bit tired of it, and there aren't many non-widescreen themes to choose from. I installed the morethemes package from the LinHES repos... I think there are still only about 3-4 themes in total that are not widescreen.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 23, 2010 5:46 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1291
Location: Orlando FL
there's a morethemes package!? what is in it?

_________________
My System


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 23, 2010 8:02 pm 
Offline
Joined: Mon Nov 22, 2010 10:20 am
Posts: 5
Code:
$ pacman -Ql morethemes | awk -F/ 'NR>5{print $6}' | sort -u
LCARS
ProjectGrayhem
ProjectGrayhem-wide
Retro-wide
TransBlue
Willi
bando-blue
blootube
blootube-wide
blootubelite-wide
blue-abstract-wide
neon-wide


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 23, 2010 9:30 pm 
Offline
Joined: Mon Dec 24, 2007 9:47 am
Posts: 535
Location: Ottawa, Canada
hmmm. looks like a left over from 6.02 (mythtv 0.22) which would have supported those themes.

As I mentioned mythtv 0.23 (LinHES 6.03) had a major UI rewrite and those themes were not converted.

I really like Blue Abstract in the new themes. I do use it as well for one of my 4:3 screens. It works reasonably well though you get a few fields which get truncated such as current time. But it is a reasonable compromise to get all the nifty artwork.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 24, 2010 10:54 am 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1291
Location: Orlando FL
I have an upgraded 6.02 and I have all of those themes already. I too like Blue abstract but I have a documented issue of 4 digit times being broken. i.e. 10:00

_________________
My System


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 27, 2010 4:13 pm 
Offline
Joined: Sat May 12, 2007 2:41 am
Posts: 49
Location: Southern Germany
Hmm, one problem might be that I don't have the MythCenter theme. All themes I have available are listed in post #3.

Tried pacman -S mythtemes-0.23-29 but that did not help.

The directory MythCenter is in /usr/share/mythtv/themes (owned by root, permissions 755) but the theme is not available in the list of available UI-themes.

Is there a way to fix this?


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 
Go to page 1, 2  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu