View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri Jun 15, 2012 8:43 pm 
Offline
Joined: Wed Apr 12, 2006 3:05 pm
Posts: 210
Location: Little Rock
I am running the latest stable R7 on the following system:

Gigabyte X48-DS5 MB with Intel Quad Core 2.66MHZ
4MB RAM
NVIDIA GeForce 9800GTX
HDHomerun (on network)
WD 1TB SATA HD
Seagate 250GB PATA HD
Samsung 500GB PATA HD
Denon AVR2112CI Receiver
Sony 5.1 speakers + subwoofer

The motherboard has optical SPDIF out which connects to the optical in port on my Denon receiver. The sound worked great on my old Pioneer receiver, but after upgrading to the Denon, SD sound will occasionally "pop" from the left rear speaker. In MythTV General config, I have the option checked to upmix stereo to 5.1. Actual 5.1 (from HD or DVD/BD sources) sound is great and seems to be coming loudly from all speakers. When I watch an SD program, the sound mainly comes from the front speakers with a faint sound coming from the rear speakers. Occasionally a full volume snippet of sound will emanate from the left rear speaker, causing everyone to jump as if a person just yelled something over there. We've mostly gotten used to it, but now my wife is entertaining more friends and it is driving them (and her) crazy. I don't even know how to start troubleshooting this.

I've double-checked the speaker connections, but since MythTV HD programs and Blu-Ray discs sound fine, I don't think that is the problem. I don't see anything in MythTV to check or change. I'm not convinced it's a MythTV problem but have not received a reply in the Denon forums so thought I would try here as well. If there's anything else I can try to fix or even better explain the problem, please let me know.

Thanks.


Top
 Profile  
 
PostPosted: Sat Jun 16, 2012 5:23 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1175
Location: SC
The pops are because you are upmixing. If you turn off upmixing they will go away. Or if you want to keep upmixing look through your mythfrontend.log for a message about buffer could not be increased. Then it gives an echo command. Put that command in /etc/runit/1.local and reboot. My command in 1.local is:
Code:
echo 128 | tee /proc/asound/card0/pcm1p/sub0/prealloc
Yours could be different due to a different board.


Top
 Profile  
 
PostPosted: Sat Jun 16, 2012 6:49 pm 
Offline
Joined: Wed Apr 12, 2006 3:05 pm
Posts: 210
Location: Little Rock
Thanks for that! I've tried diagnosing that issue (documented in another forum) and didn't see that it required adding the line to 1.local to get it to "take." I used the error's suggestion and tried directly changing it with sudo (even using nano to edit the prealloc file directly) with no success. I found the file was actually being written at a higher level. I tried changing it at a higher level and making the file 777 so mythtv could change it as required, but each time I look at /proc/asound/card0/pcm1p/sub0/prealloc it's 64 instead of 128. I just tried inserting it to 1.local and will see if it works when I reboot.


Top
 Profile  
 
PostPosted: Sat Jun 16, 2012 6:52 pm 
Offline
Joined: Wed Apr 12, 2006 3:05 pm
Posts: 210
Location: Little Rock
DoomedTX wrote:
Thanks for that! I've tried diagnosing that issue (documented in another forum) and didn't see that it required adding the line to 1.local to get it to "take." I used the error's suggestion and tried directly changing it with sudo (even using nano to edit the prealloc file directly) with no success. I found the file was actually being written at a higher level. I tried changing it at a higher level and making the file 777 so mythtv could change it as required, but each time I look at /proc/asound/card0/pcm1p/sub0/prealloc it's 64 instead of 128. I just tried inserting it to 1.local and will see if it works when I reboot.


Edit: I meant to say the prealloc file is 128 so your suggestion worked!

Update: after a reboot, I watched a program that I know earlier in the day caused the popping noises, and so far it seems ok. I might just turn off upmixing anyway because it doesn't seem to do much. When not popping there's a very faint noise from the rear speakers, but the difference between HD and SD programs is very obvious. With SD you'd never guess it was being upmixed to the rear speakers because you can hardly hear anything from them without putting your ear right up to it. I will be happy (more importantly the WAF will improve) with getting rid of the popping sounds so I will probably leave well enough alone.

Thanks for pointing me in the right direction and helping me fix that annoyance.


Top
 Profile  
 
PostPosted: Tue Jun 19, 2012 9:32 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1300
Location: Orlando FL
you probably can upmix on your Dennon

_________________
My System


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu