View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 8 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Tue Mar 14, 2017 4:59 pm 
Offline
Joined: Thu Sep 08, 2005 4:46 pm
Posts: 81
Hi,

What is the correct way to change system type from MasterBackend with frontend (Mythfrontend) to MasterBackend only.

I tried to change systemtype in linhes config and disable mythfrontend but the system is crashing and my pc poweroff few minutes later. Seem to be rely on Xymon state... idle.sy ?

Maybe i can just disable the xorg check or activate analogic mode so the server don't notice it run headless.

By the way the Linhes server is running great with a monitor connected to it.

Thanks for your input
Bob


Top
 Profile  
 
PostPosted: Tue Mar 14, 2017 6:01 pm 
Offline
Joined: Tue Jul 01, 2014 6:49 am
Posts: 81
Not sure how to permanently change it, but in the interim, if you open a terminal and enter
Code:
sv stop frontend
that will shut down the front end process.

Granted it will restart the next time you reboot...but on the plus side if you need the front end, all you have to do is open a terminal and enter
Code:
sv start frontend


Top
 Profile  
 
PostPosted: Wed Mar 15, 2017 9:32 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 988
Location: SC
Bob wrote:
What is the correct way to change system type from MasterBackend with frontend (Mythfrontend) to MasterBackend only.
In Service Menu > LinHES Settings > Host > uncheck Run Frontend. This setting basically runs
Code:
sudo remove_service.sh frontend
which controls if the service runs at startup.

Are you sure it is a crash or just a shutdown that is happening? The shutdown is probably from the setting in mythtv-setup > General > Shutdown/Wakeup Options > Idle shutdown timeout. Set that to 0 to disable shutdown. You can also keep the system from shutdown using mythshutdown --lock if the idle shutdown setting is other than 0.


Top
 Profile  
 
PostPosted: Thu Mar 16, 2017 6:44 pm 
Offline
Joined: Thu Sep 08, 2005 4:46 pm
Posts: 81
Hi again,

Sorry for the delay

I tried tonight to uncheck run frontend from service menu like brfransen said.

Surprinsingly the run frontend box was not checked. So i checked it and wait 2 minutes and reboot. After I unchecked it and the computer turn off. I turned it back on again. Fews minutes later the computer was shutoff. The system turn off systematically after fews minutes when i turn it back on.

The system was running great since my first post with a monitor connected to it (in frontend mode).

Where should i start to look (what logs)? The WAF is in danger... :cry:

Thanks
Bob


Top
 Profile  
 
PostPosted: Thu Mar 16, 2017 7:03 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 988
Location: SC
After unchecking Run Frontend you hit Finish and a progress bar came up right?

Did you adjust the idle timeout or try the mythshutdown lock command I gave in the previous post?


Top
 Profile  
 
PostPosted: Sun Mar 19, 2017 9:46 am 
Offline
Joined: Thu Sep 08, 2005 4:46 pm
Posts: 81
Hi,

Thanks brfransen.

I did the command shell command because my frontend was already not enable:

Code:
mythshutdown lock


And i happy to tell you that my system is up and running since 2 days. The mythweb interface is snappier with mythfrontend disable on my relatively old pc server (Pentium4)...

I have one more question remaining.
    Do i have to run this command at every reboot of my server or it is permanent? Or should i add it to cron tab?

Thanks
Bob


Top
 Profile  
 
PostPosted: Sun Mar 19, 2017 11:57 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 988
Location: SC
I am not sure if mythshutdown --lock is preserved after a reboot. The correct way to disable myth shutting down the system is to change the Idle timeout in mythtv-setup to 0.


Top
 Profile  
 
PostPosted: Sun Mar 19, 2017 6:21 pm 
Offline
Joined: Thu Sep 08, 2005 4:46 pm
Posts: 81
Everything seem good now.

Operations i did:
    sudo add_service.sh frontend
    Rebooted
    set Idle timeout in mythtv-setup to 0 (By default it was set to 40 because it was a new installation (should be 0 i think))
    sudo remove_service.sh frontend

Thanks a lot :D
Bob


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu