View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 6 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Tue Jun 09, 2009 6:38 pm 
Offline
Joined: Wed Jun 03, 2009 8:40 am
Posts: 5
I finally got my SVideo OUT working.
The system:
LinHES R6
NVidia eGeForce 6200
SVideo out to Plain old TV Set, NTSC

The persistent problem I was chasing was that the image was under-scanned a bit leaving black borders on the left and right. The left was ok, as it was not really visible, but the right was leaving a good 1/4 inch of black, and worse, it was uneven, bowed in the middle.

I tried the adjustments in the myth screen adjustment wizard to no avail. I could move the borders inward, but not outward. These adjustments appear to only move the Myth display within the X11 screen, and it was the x11 screen itself that needed to expand and scrunch over to the right a bit.

Not being familiar with the intricacies of xorg and the X-window system, and the options available, it took me considerable digging. But adding the setting 'Option "TVOverscan" "0.5" ' to /etc/x11/xorg.conf solved the problem.

Here is the relevant portion of my file.

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "DPI" "100 x 100"
Option "TVStandard" "NTSC-M"
Option "ConnectedMonitor" "TV"
Option "TVOutFormat" "SVIDEO"
Option "TVOverScan" "0.5"
Option "NoLogo" "1"
Option "DigitalVibrance" "1"
EndSection

The display is still ever so slightly off center, could stand to move right about 1/2 inch, thus with this amount of overscan, a tiny bit of the left edge is lost, but not an objectionable amount. I have not found any centering adjustments. If anyone knows how to center the image I would appreciate a post to that effect. But the end result with this setting is quite acceptable.

Hopefully this will help the next person fighting this battle.

Nathan


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 09, 2009 11:24 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
As I mentioned in your other thread the preferred way of doing this these days is using the nvidia-settings utility to tune things like overscan. There is more information on doing this here and on the wiki.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 10, 2009 3:28 pm 
Offline
Joined: Wed Jun 03, 2009 8:40 am
Posts: 5
Yeah, I spent most of a day trying to figure out how to get that thing to run. No luck...

Simply saying information is here and there on the wiki doesn't help much. Much of what I found was either just wrong, didn't work as claimed, or did not apply to R6. Scratch much. Make that everything.

No doubt it's in there somewhere. But after hours and hours searching and digging, I'm giving up on nvidia-settings for the moment.

LinHES is a great system, but getting it configured and working properly takes a touch of esoteric arcanorum that many even very experienced computer folks do not have.

Cheers,
Nathan


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 10, 2009 5:57 pm 
Offline
Joined: Fri Apr 02, 2004 10:08 am
Posts: 1637
Location: Virginia, USA
One of the best ways to give back to the project, then, and make it easier for the next person, is to revise the wiki with what you discovered.

Just add it to the top and state that it's the process you used to get things to work with R6.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 10, 2009 6:21 pm 
Offline
Joined: Wed Nov 16, 2005 8:55 pm
Posts: 1381
Location: Farmington, MI USA
ngregory wrote:
Yeah, I spent most of a day trying to figure out how to get that thing to run. No luck...
nvidia-settings in an xterm should fire it right up. You want to run this as root (su) so you have rights to write the information to the xorg.conf file.

A quick search for nvidia-settings on knoppmythwiki.org and in these forums turns up many hits - The utility isn't R6 or any other KM-version specific, it's available with the nVidia drivers.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 10, 2009 10:07 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Status of some of the key pages found by searching for nvidia-settings on the wiki:

Current as of R5.5. For R6 you only need to realize that the virtual console numbers are different. But you can try the different ones quickly enough. http://www.knoppmythwiki.org/index.php?page=NvidiaSetup

Still mostly valid. Recompiling the drivers is no longer needed or practical. http://www.knoppmythwiki.org/index.php?page=PictureQualityIssues

Current as of R5.5. For R6 you need to translate the directions to use arch. http://www.knoppmythwiki.org/index.php?page=UpdateNvidiaDrivers

Somebody should probably start an R6 section and then link to stuff that's still relevant. Possibly a good project for anyone who was interested in the "Experimental Index" project...


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Google [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu