View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 10 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Jul 05, 2009 5:49 am 
Offline
Joined: Sun Sep 04, 2005 7:48 pm
Posts: 264
Location: Perth, Australia
Hi there,

I just upgraded my R6 using pacman (mythtv and nvidia 185.18.14), and noticed that all my recordings were playing in odd colours/colors. Green grass was blue, and faces were pink...

Turns out that mythtv was "taking control" of the picture, and setting the hue to -1000 whenever it started to play a recording/video.

I could use nvidia-settings to set the hue value back to normal, but then it would be re-set back to -1000 everytime i watched somethig... not ideal..

The fix was to disable mythtv from managing the colours, in the playback section (there is a check box that needs to be unset). Sorry, machine is off at the moment, so cant be more specific.

If you didnt have this option checked, you probably wouldnt have noticed.

Hope this helps someone else who gets a surprise when they upgrade.

Cheers,

Nathan

_________________
LinHES: R6 | MB: Asus M3N-H/HDMI | CPU: AMD ??Mhz
Capture: 2xHDHR DVB-T
Graphics: Onboard 8300|PSU: Corsair vx450w
Cooling: Zalman cu?,
Display: Benq xx projector


Top
 Profile  
 
PostPosted: Sun Jul 05, 2009 4:30 pm 
Offline
Joined: Sun Aug 28, 2005 7:07 pm
Posts: 821
Location: Melbourne, Australia
Hi Nathan,

I had that problem the other day: Fixed it permanently by using the remote. Menu -> Picture Controls -> Hue (working from memory here, so the middle menu item could be incorrectly named). Set it back to 50% and all working again.

Regards,

Mike

_________________
*********************
LinHES 7.4
Australian Dragon
*********************


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jul 07, 2009 10:16 am 
Offline
Joined: Fri Oct 15, 2004 7:39 am
Posts: 57
Location: Easton, PA
I had the same issue. Everybody looked like a smurf with a blue color to them. To correct: Play a recording, hit menu>picture> hue
- slide it to 50% or whatever looks good on your system

_________________
R6: ASUS M2NPV-VM motherboard|4 gig or RAM| AMD 3800+ dual core processor|1 TB HD|Nvidia 8600GT graphics card|HDHomeRun|PVR-1212 |Zotac Ion AU frontend


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 08, 2009 1:15 am 
Offline
Joined: Wed Feb 07, 2007 11:28 pm
Posts: 19
Location: Phx, AZ
Ditto, I had the exact same problem. I did the same as hackmeister and manicmike. Problem solved and no more Smurfs. I tried the first method mentioned and didn't have any luck with it.

_________________
R6.01.00
ASUS M3A78
AMD Athlon 64 X2 7750 Kuma 2.7GHz
2GB DDR2 1066
2 Seagate's (.75 & 1.5) 2.25Tb
GIGABYTE GV-NX84S512HP 8400GS 512MB
PVR-150,PVR-250, 2X HVR-1250
Silverstone GD01B-MXR with Imon


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 08, 2009 1:26 am 
Offline
Joined: Sun Sep 04, 2005 7:48 pm
Posts: 264
Location: Perth, Australia
From what my simple brain can understand, the option i have taken is to stop mythtv attempting to set picture controls (colours) - leave it to nvidia... the second option is to allow mythtv to set picture controls, but set the hue value to midrange (50%). i think i'll go for the second option when i get home, and see if i still get smurfs.

_________________
LinHES: R6 | MB: Asus M3N-H/HDMI | CPU: AMD ??Mhz
Capture: 2xHDHR DVB-T
Graphics: Onboard 8300|PSU: Corsair vx450w
Cooling: Zalman cu?,
Display: Benq xx projector


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 08, 2009 1:50 am 
Offline
Joined: Sun Aug 28, 2005 7:07 pm
Posts: 821
Location: Melbourne, Australia
It's probably something really simple like someone at nvidia re-defining normal from 0% to 50% (in fact I'd almost bet money that this is exactly what happened).

Mike

_________________
*********************
LinHES 7.4
Australian Dragon
*********************


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 15, 2009 4:13 pm 
Offline
Joined: Thu Sep 30, 2004 11:29 am
Posts: 2419
Location: Mechanicsburg, PA
I discovered that this is more general than the interaction between the nVidia drivers and MythTV settings. It affects the color of all MPEG2 playback when vdpau is used, whether using MythTV's Internal player or mplayer (or, I would guess, any player that used vdpau).

Does anyone have ideas as to how to solve this in general without changing MythTV settings? FYI, flyspray bug is http://linhes.org/flyspray/index.php?do ... ask_id=437

_________________
KnoppMyth R5.5
MythiC Dragon v2.0
Join the KnoppMyth Frappr!


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 16, 2009 11:38 am 
Offline
Joined: Thu Sep 30, 2004 11:29 am
Posts: 2419
Location: Mechanicsburg, PA
I have a correction to my own post. vdpau isn't the problem. A bug in my in-progress mplayer-wrapper.pl was misfiring, and when I saw the color problems, I assumed vdpau was in use. Actually, xv was in use. You can verify the general problem by playing most videos (MPEG2 for certain) with mplayer, using "-vo xv" as a parameter.

The problem is still more general than the interaction between MythTV and the nvidia drivers, as it affects mplayer as well. It seems to be a bug in how the nvidia drivers handle xv.

New bug filed: http://knoppmyth.net/flyspray/index.php ... ask_id=438

_________________
KnoppMyth R5.5
MythiC Dragon v2.0
Join the KnoppMyth Frappr!


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 16, 2009 11:52 am 
Offline
Joined: Thu Sep 30, 2004 11:29 am
Posts: 2419
Location: Mechanicsburg, PA
manicmike wrote:
It's probably something really simple like someone at nvidia re-defining normal from 0% to 50% (in fact I'd almost bet money that this is exactly what happened).

You may be right, but in my testing, reds appear as blue, and blues appear as red; it seems like they swapped the values somewhere.

_________________
KnoppMyth R5.5
MythiC Dragon v2.0
Join the KnoppMyth Frappr!


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 16, 2009 12:43 pm 
Offline
Joined: Thu Sep 30, 2004 11:29 am
Posts: 2419
Location: Mechanicsburg, PA
Thanks to nmcaullay's initial post, I made Tweaker turn off the option that tells MythTV to mess with the color space. Building and testing now.

_________________
KnoppMyth R5.5
MythiC Dragon v2.0
Join the KnoppMyth Frappr!


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Baidu [Spider] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu