View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 2 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Jul 27, 2008 4:04 am 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1995
Location: /dev/null
R5.5 installed the 96.43.05 driver and everything works EXCEPT OpenGL on my machine (haven't tested xvmc either). If I set my painter to OpenGL and restart mythfrontend, I get a black screen. I've been using the Qt painter fine, but I'd prefer to use OpenGL.

My board has an integrated GF4 and I know even back in R5F27, in order to get the OpenGL stuff to work properly, I had to get the old driver from R5F1 this wiki page. My R5.5 box works in ever other respect, and I'm hesitant to try these steps on it without some guidance from folks who know.

Can I follow the same steps to get that driver off the R5F1 iso for R5.5 or will it not work due to differences in the kernel, other stuff that's over my head?

Failing that, there is an IA32 driver on the nvidia website that has the same version number (1.0-8776) that I ran successfully under R5F1. If I got it, would it just install correctly (using the # sh NVIDIA-Linux-x86-1.0-8776-pkg1.run) or would that too have problems and roach my system?

Here are the steps from that wiki page from my own notes installing R5F27:
Code:
Copy the iso to /myth/tmp
# cd /myth/tmp
# mkdir theCD
# mkdir theCloopImage
# modprobe cloop
# mount /myth/tmp/KnoppMythR5F1.iso ./theCD -t iso9660 -o loop,ro
# mount ./theCD/KNOPPIX/KNOPPIX ./theCloopImage -t iso9660  -o ro,loop=/dev/cloop0
# ls theCloopImage/

bin   dev  home    knoppmyth       lib    mnt  proc  sbin  sys  usr  vmlinuz
boot  etc  initrd  knoppmyth-sata  media  opt  root  srv   tmp  var

# tar -cf - -C theCloopImage/usr/src/debs/ nvidia | tar -xvf -

nvidia/
nvidia/common/
nvidia/common/nvidia-kernel-common_20051028+1_all.deb
nvidia/latest/
nvidia/latest/install.sh
nvidia/latest/nvidia-glx-dev_1.0.8776-1_i386.deb
nvidia/latest/nvidia-glx_1.0.8776-1_i386.deb
nvidia/latest/nvidia-kernel-2.6.18-chw-13_1.0.8776-1+2.6.18-chw-13-10.00.Custom_i386.deb
nvidia/legacy/
nvidia/legacy/install-legacy.sh
nvidia/legacy/nvidia-glx-legacy-dev_1.0.7184-2_i386.deb
nvidia/legacy/nvidia-glx-legacy_1.0.7184-2_i386.deb
nvidia/legacy/nvidia-kernel-legacy-2.6.18-chw-13_1.0.7184-2+2.6.18-chw-13-10.00.Custom_i386.deb

# ls -l nvidia/

total 12
drwxr-sr-x 2 root src 4096 Nov 18  2006 common
drwxr-sr-x 2 root src 4096 Nov 19  2006 latest
drwxr-sr-x 2 root src 4096 Nov 19  2006 legacy

# init 1
# pkill xinit

# cd /myth/tmp/nvidia/latest/

# dpkg -i --force-conflicts --force-overwrite *.deb
You should get the following errors:
Errors were encountered while processing:
 nvidia-glx_1.0.8776-1_i386.deb
 nvidia-glx-dev
Then run:
# dpkg -P nvidia-kernel-2.6.18-chw-13
# dpkg -P nvidia-glx-legacy-96xx
# dpkg -i --force-conflicts --force-overwrite *.deb

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 27, 2008 4:53 am 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1995
Location: /dev/null
Update... neither of the above methods work. I did a quick test on my test R5.5 hardrive (old 80 gig drive I use to test dangerous stuff like this on).

The driver from the nvidia website wouldn't install (failed to compile a kernel driver).

Code:
 No precompiled kernel interface was found to match your kernel; would you
  like the installer to attempt to download a kernel interface for your kernel
  from the NVIDIA ftp site (ftp://download.nvidia.com)?


To which I said yes.

Code:
No matching precompiled kernel interface was found on the NVIDIA ftp site;
  this means that the installer will need to compile a kernel interface for
  your kernel.


To which I said OK

Code:
ERROR: Unable to build the NVIDIA kernel module.

 ERROR: Installation has failed.  Please see the file
         '/var/log/nvidia-installer.log' for details.  You may find
         suggestions on fixing installation problems in the README available
         on the Linux driver download page at www.nvidia.com.


I followed the wiki page instructions and everything seems to work until I rebooted. Now it's giving the c7 respawning too fast error. Guess I'm out of luck for OpenGL under R5.5 with my aged hardware.

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu