View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Apr 17, 2008 8:53 am 
Offline
Joined: Thu Feb 09, 2006 9:34 am
Posts: 10
I am having a problem with mkv files being played back. Mplayer will play them just fine, sound will be fine too, but I can't seek back and forth with lirc or the keyboard. If I call mplayer from the command line and try and seek, I get this error: (ignore the display errors)

Code:
Playing 720p Test.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AAC), -aid 0, -alang und
[mkv] Track ID 3: subtitles (S_TEXT/ASS), -sid 0, -slang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1280x544  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
vo: couldn't open the X11 display ()!
vo: couldn't open the X11 display ()!
VO XOverlay need a subdriver
[gl] using extended formats. Use -vo gl:nomanyfmts if playback fails.
vo: couldn't open the X11 display ()!
vo: couldn't open the X11 display ()!
[VO_SDL] Using driver: fbcon.
vo: couldn't open the X11 display ()!
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1280 x 544 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.35:1 - prescaling to correct movie aspect.
VO: [sdl] 1280x544 => 1280x544 Planar YV12
[ASPECT] Warning: No suitable new res found!
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
Cannot seek in this file..361 ct:  0.000   1/  1 ??% ??% ??,?% 0 0
Cannot seek in this file..132 ct:  0.039  25/ 25 95% 54%  4.2% 17 0
Cannot seek in this file..011 ct:  0.042  39/ 39 67% 55%  3.4% 17 0
Cannot seek in this file..001 ct:  0.043  53/ 53 54% 55%  3.8% 17 0


From what I have gleaned while searching, seeking in mkv files works fine for most people. Here's what I'm running:

fresh KnoppMyth R5F27

Code:
cat /etc/mythtv/version
Library API version     : 0.20.20070821-1
Source code version     : 14463M


Code:
mplayer -version
MPlayer 1.0rc2-4.1.2 (C) 2000-2007 MPlayer Team
CPU: AMD Sempron(tm)   2500+ (Family: 6, Model: 8, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE


In Video Settings I have added mkv as a file type to use the default player, which is mplayer -fs -zoom -quiet -vo xv %s.

Any thoughts why I can't get it to seek right?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 17, 2008 11:51 pm 
Offline
Joined: Thu Feb 09, 2006 9:34 am
Posts: 10
After banging my head against multiple brick walls, I have come up with a Valuable Free Clue.

The internet would have me believe that all I need to do is add the configure option --enable-largefiles to fix the problem seeking in >2gb files. I tried that and had the same problem as before.

BUT...it was about that time that I decided to try playing the file from the local HD instead of the samba mounted windows file share..bingo. Everything works as it should from the local filesystem. Now on to figure out how to handle large files on a remote windows filesystem....Anyone? Bueller?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 18, 2008 12:02 am 
Offline
Joined: Thu Feb 09, 2006 9:34 am
Posts: 10
Oh thank you lord for letting me speak out loud, solve my own problems, and hopefully help other noobs such as myself in the future.

I changed my startup script that mounts all the windows shares to add lfs support with the suffix

,lfs

works like a champ.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 18, 2008 1:07 am 
Offline
Joined: Wed Jul 28, 2004 2:47 pm
Posts: 7
Location: South Africa
Nice one - was wondering why my 2gig files on my samba share always bombed out while watching - never bothered to troubleshoot


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jun 23, 2008 5:36 pm 
Offline
Joined: Fri Sep 15, 2006 12:16 pm
Posts: 292
cifs is a more recent version of a samba file system that
has lfs enabled by default. That is how I fixed my 2gig
smbfs limit.

Cliff


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu