LinHES Forums

Auto expire has stopped working - any ideas?
Page 1 of 1

Author:  ssteward [ Tue Feb 26, 2008 4:07 pm ]
Post subject:  Auto expire has stopped working - any ideas?


The auto expire on my box appears to have stopped deleting shows and therefore the disc fulls up and the box falls over. It has worked fine for the past year or so and is set to ~3GB. Any idea what could be causing this?

I've been deleting shows by hand to get a bit of space but in the end it'll fill up again of course.

I have two discs and I think the big one that I mount at /myth/tv may be dying. I'm not sure how to confirm my suspicions.

I'm on Release 5 Beta 7. Perhaps I'll just buy a new disc and rebuild the machine on the latest version.

Author:  cecil [ Tue Feb 26, 2008 4:38 pm ]
Post subject: 

And the logs state?

Author:  tscholl [ Tue Feb 26, 2008 6:21 pm ]
Post subject: 

You did happen to change a setting to "Delete files Slowly" ?

Author:  ssteward [ Wed Feb 27, 2008 5:13 pm ]
Post subject: 

The log has entries like:

AutoExpire: ERROR when trying to autoexpire file: /myth/tv/blah...mpg File doesn't exist. Database metadata will not be removed.


Error deleting file: /myth/tv/blah...mpg Operation not permitted


Error deleting file: /myth/tv/blah...mpg. Keeping metadata in database.

I'm on R5B7, the only autoexpire settings I have are in Setting|TV|General which offers a drop down with 'oldest' or 'lowest priority' recordings first and a check box to default autoexpire on for new recordings.

Author:  ssteward [ Thu Mar 13, 2008 4:39 pm ]
Post subject: 

After a number of reboots (needed after the box locked up) and deleting lots of stuff by hand, it's started working again. How odd.

Author:  ssteward [ Sun Mar 30, 2008 7:15 pm ]
Post subject: 

Actually, this problem's back. I suspected it was down to corrupt database tables as my hard disc has filled up. I ran through the steps in the sticky post on this topic but I coudn't find any errors.

I have a few shows that I can't delete. If I try to then the show comes back a few seconds later. The logs say 'file can't be deleted, keeping metadata'. I've seen a manual way to trick the system into deleting the shows by renaming a blank file to the name of the file that won't delete and then deleting in the FE. I think there are a lot of files like this so it could be a long process. Is there a way to clean this up without the hard manual work?

Thanks S

Author:  Kirk [ Sun Mar 30, 2008 11:50 pm ]
Post subject: 

You could try the scripts in this thread.

Author:  mythedoff [ Tue Apr 22, 2008 10:35 am ]
Post subject: 

ssteward wrote:

I have a few shows that I can't delete. If I try to then the show comes back a few seconds later.

I'm seeing this problem. Not necessarily the same cause as yours but mine is the result of using the removecommercials script. I just delete the offending file and then remove the .old from the renamed original. I am then able to delete the recording in the usual way.

FWIW, I had been using that script because neither the myth2xvid nor the myt2xvid3 scripts are removing the commercials.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group