View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 28 posts ] 
Go to page Previous  1, 2

Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject:
PostPosted: Tue Sep 09, 2008 11:33 pm 
Offline
Joined: Fri Jan 06, 2006 9:35 pm
Posts: 64
Location: Northern Kentucky
Thanks for the post.

I followed the code listed in the box. Seemed to have completed properly. Rebooted and did a small recording. It still spits out the ipodfeed XML file but no file.



Do I need to run the commands in the edit sections?

Edit: Note that you can add gsm and theora support by doing
apt-get install on libtheora-dev and libgsm1-dev and adding
--enable-libtheora and --enable-libgsm to the ./configure command.

Edit: I have found that compiling SVN ffmpeg causes the stock
nuvexport to fail. I have not attempted to use the latest nuvexport
to fix this. DVD creation (mytharchive) works fine though.

I really don't know what I am doing so if you could expand on that further...




The log doesn't mean much to me. I don't know what to look for in it.





2008-09-10 01:05:02.608 Started recording: test d (Manual Record) "Wed Sep 10 01:05:00 2008": channel 1051 on cardid 1, sourceid 1
2008-09-10 01:05:24.714 JobQueue: Commercial Flagging Starting for test d (Manual Record) "Wed Sep 10 01:05:00 2008" recorded from channel 1051 at Wed Sep 10 01:05:00 2008
2008-09-10 01:05:24.980 Using runtime prefix = /usr
2008-09-10 01:05:24.990 Empty LocalHostName.
2008-09-10 01:05:24.991 Using localhost value of dumbo
2008-09-10 01:05:25.051 New DB connection, total: 1
2008-09-10 01:05:25.057 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:05:25.060 Closing DB connection named 'DBManager0'
2008-09-10 01:05:25.069 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:05:25.078 New DB connection, total: 2
2008-09-10 01:05:25.086 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:05:25.149 Connecting to backend server: 192.168.1.109:6543 (try 1 of 5)
2008-09-10 01:05:25.153 Using protocol version 40
2008-09-10 01:05:25.154 MainServer::HandleAnnounce Monitor
2008-09-10 01:05:25.156 adding: dumbo as a client (events: 0)
2008-09-10 01:05:25.157 MainServer::HandleAnnounce Monitor
2008-09-10 01:05:25.158 adding: dumbo as a client (events: 1)
2008-09-10 01:05:31.349 AFD: Opened codec 0xb3d1e480, id(MPEG2VIDEO) type(Video)
2008-09-10 01:05:31.351 AFD: codec AC3 has 6 channels
2008-09-10 01:05:31.353 AFD: Opened codec 0xb3d1ea20, id(AC3) type(Audio)
2008-09-10 01:06:00.645 TVRec(1): Changing from RecordingOnly to None
2008-09-10 01:06:00.663 Finished recording test d (Manual Record) "Wed Sep 10 01:05:00 2008": channel 1051
2008-09-10 01:06:00.665 Reschedule requested for id 0.
2008-09-10 01:06:00.702 Scheduled 14 items in 0.0 = 0.00 match + 0.03 place
2008-09-10 01:06:01.062 Finished recording test d (Manual Record) "Wed Sep 10 01:05:00 2008": channel 1051
2008-09-10 01:06:01.270 Using runtime prefix = /usr
2008-09-10 01:06:01.273 Empty LocalHostName.
2008-09-10 01:06:01.274 Using localhost value of dumbo
2008-09-10 01:06:01.295 New DB connection, total: 1
2008-09-10 01:06:01.300 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:06:01.303 Closing DB connection named 'DBManager0'
2008-09-10 01:06:01.304 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:06:01.307 New DB connection, total: 2
2008-09-10 01:06:01.308 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:06:01.312 Current Schema Version: 1214
2008-09-10 01:06:03.625 Using runtime prefix = /usr
2008-09-10 01:06:03.629 Empty LocalHostName.
2008-09-10 01:06:03.630 Using localhost value of dumbo
2008-09-10 01:06:03.652 New DB connection, total: 1
2008-09-10 01:06:03.657 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:06:03.660 Closing DB connection named 'DBManager0'
2008-09-10 01:06:03.662 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:06:03.664 New DB connection, total: 2
2008-09-10 01:06:03.665 Connected to database 'mythconverg' at host: localhost
2008-09-10 01:06:03.668 Current Schema Version: 1214
2008-09-10 01:06:03.809 AFD: Opened codec 0x82cffd0, id(MPEG2VIDEO) type(Video)
2008-09-10 01:06:03.811 AFD: codec AC3 has 6 channels
2008-09-10 01:06:03.812 AFD: Opened codec 0x82d0570, id(AC3) type(Audio)
2008-09-10 01:06:04.150 Preview: Grabbed preview '/myth/tv/1051_20080910010500.mpg' 1920x1088@64s
2008-09-10 01:06:06.156 AFD: Opened codec 0x82cffd0, id(MPEG2VIDEO) type(Video)
2008-09-10 01:06:06.157 AFD: codec AC3 has 6 channels
2008-09-10 01:06:06.159 AFD: Opened codec 0x82d0570, id(AC3) type(Audio)
2008-09-10 01:06:06.466 Preview: Grabbed preview '/myth/tv/1051_20080910010500.mpg' 1920x1088@64s
2008-09-10 01:06:11.335 MainServer::HandleAnnounce Monitor
2008-09-10 01:06:11.336 adding: dumbo as a client (events: 0)
QDateTime::fromString: Parameter out of range
2008-09-10 01:06:29.735 JobQueue: Started "Encode for iPod" for "test d (Manual Record)" recorded from channel 1051 at Wed Sep 10 01:05:00 2008
Starting nuvexport...
Generating cutlist
/usr/bin/mythcommflag --chanid 1051 --starttime 20080910010500 --gencutlist
2008-09-10 01:06:30.264 Using runtime prefix = /usr
2008-09-10 01:06:30.267 Empty LocalHostName.
2008-09-10 01:06:30.288 New DB connection, total: 1
2008-09-10 01:06:30.295 Closing DB connection named 'DBManager0'
2008-09-10 01:06:30.303 New DB connection, total: 2
/usr/local/bin/nuvexport --chanid=1051 --start=20080910010500 --mode=iPod --nice=19 --cutlist --nodenoise --nodeinterlace --nomultipass --mp4_codec=h264 --width 640 --height 380 --v_bitrate 1500 --filename=1051_20080910010500.temp --path=/myth/ipodfeed/
2008-09-10 01:06:30.839 MainServer::HandleAnnounce Monitor
2008-09-10 01:06:30.840 adding: dumbo as a client (events: 0)
Loading MythTV recording info.

0%
25%
50%
75%
Default resolution based on requested dimensions.
Height must be a multiple of 16.

Now encoding: test d (Manual Record): Wed Sep 10 01:05:00 2008
Encode started: Wed Sep 10 01:06:33 2008
Use of uninitialized value in pattern match (m//) at /usr/local/share/nuvexport/export/ffmpeg/MP4.pm line 196.
Use of uninitialized value in pattern match (m//) at /usr/local/share/nuvexport/export/ffmpeg/MP4.pm line 196.
2008-09-10 01:06:33.446 MainServer::HandleAnnounce Monitor
2008-09-10 01:06:33.450 adding: dumbo as a client (events: 0)
2008-09-10 01:06:33.451 MainServer::HandleAnnounce Monitor
2008-09-10 01:06:33.452 adding: dumbo as a client (events: 1)
Waiting for mythtranscode to set up the fifos.
Waiting for mythtranscode to set up the fifos.
Waiting for mythtranscode to set up the fifos.
Starting ffmpeg.

processed: 0 of 1689 frames at 0 fps (~%, eta: unknown)
processed: 0 of 1689 frames at 0 fps (~%, eta: unknown)
processed: 0 of 1689 frames at 0 fps (~%, eta: unknown)
processed: 0 of 1689 frames at 0 fps (~%, eta: unknown)
processed: 0 of 1689 frames at 0 fps (~%, eta: unknown)
processed: 0 of 1689 frames at 0 fps (~%, eta: unknown)
processed: 0 of 1689 frames at 0 fps (~%, eta: unknown)

ffmpeg had critical errors:

ffmpeg: unrecognized option '-me'

Cleaning up temp files.
Cleaning up child processes.
Nuvexport encoding seems to have failed
/usr/local/bin/MP4Box -add /myth/ipodfeed/1051_20080910010500.temp.mp4 /myth/ipodfeed/1051_20080910010500.ipod.mp4
(Feature Not Supported)Unknown input file type
Error importing /myth/ipodfeed/1051_20080910010500.temp.mp4: Feature Not Supported
MP4Box cleanup seems to have failed
Nuvexport completed, starting xml generation...
"test_d__Manual_Record_-Wed_Sep_10_01_05_00_2008-20080910" has been added to the feed.
XML file created for "test_d__Manual_Record_-Wed_Sep_10_01_05_00_2008-20080910" : Yipeee
Cleaning up temporary files
rm -f /myth/ipodfeed/1051_20080910010500.temp.mp4
Generating cutlist
/usr/bin/mythcommflag --chanid 1051 --starttime 20080910010500 --clearcutlist
2008-09-10 01:06:37.534 Using runtime prefix = /usr
2008-09-10 01:06:37.537 Empty LocalHostName.
2008-09-10 01:06:37.575 New DB connection, total: 1
2008-09-10 01:06:37.585 Closing DB connection named 'DBManager0'
2008-09-10 01:06:37.596 New DB connection, total: 2
2008-09-10 01:06:37.607 Cutlist set to:
test d (Manual Record) is ready for your ipod
2008-09-10 01:06:37.627 JobQueue: Finished "Encode for iPod" for "test d (Manual Record)" recorded from channel 1051 at Wed Sep 10 01:05:00 2008.
2008-09-10 01:07:30.887 MainServer::HandleAnnounce Monitor
2008-09-10 01:07:30.889 adding: dumbo as a client (events: 0)
QDateTime::fromString: Parameter out of range
2008-09-10 01:07:39.805 MainServer::HandleAnnounce Monitor
2008-09-10 01:07:39.807 adding: dumbo as a client (events: 0)
2008-09-10 01:07:40.025 MainServer::HandleAnnounce Monitor
2008-09-10 01:07:40.027 adding: dumbo as a client (events: 0)
2008-09-10 01:07:46.037 MainServer::HandleAnnounce Monitor
2008-09-10 01:07:46.038 adding: dumbo as a client (events: 0)
QDateTime::fromString: Parameter out of range
2008-09-10 01:08:29.687 AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
2008-09-10 01:17:02.275 MainServer::HandleAnnounce Monitor
2008-09-10 01:17:02.277 adding: dumbo as a client (events: 0)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 10, 2008 7:47 am 
Offline
Joined: Fri Feb 24, 2006 4:39 pm
Posts: 30
Location: Seattle, Washington
Jorin,

I'd suggest editing your script to add '--debug' to the nuvexport command, or just try running nuvexport from the command line and see if you get the same result.

The debug command causes nuvexport to simply print out the commands it would execute, rather than try to encode the video.

Once you have a copy of the commands used, look for that unrecognized option "-me" in the ffmpeg command--it might be part of a show title that needs to be surrounded with quotes, or maybe the "-me" option has changed--I notice that ffmpeg has an option -me_threshold--maybe that is being incorrectly abbreviated?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 07, 2008 3:54 pm 
Offline
Joined: Fri Nov 07, 2008 3:49 pm
Posts: 1
ffmpeg | grep method
FFmpeg version SVN-r14260, Copyright (c) 2000-2008 Fabrice Bellard, et al.
...
-me_method <int> E.V.. set motion estimation method
-me <int> E.V.. set motion estimation method (deprecated, use me_method instead)
...

as you can see, ffmpeg used to have this option for a while and now just doesn't. Use -me_method instead.


Top
 Profile  
 
 Post subject: Also worked
PostPosted: Sun Aug 16, 2009 8:12 pm 
Offline
Joined: Wed Mar 30, 2005 12:42 pm
Posts: 12
Adding:

TERM=xterm-color
export TERM

to /etc/init.d/mythtv-backend also appears to work for me.


Top
 Profile  
 
 Post subject: ffmpeg issue?
PostPosted: Sat Feb 06, 2010 2:06 pm 
Offline
Joined: Fri Sep 07, 2007 11:57 pm
Posts: 166
I too did a clean install of 5.5 a while back and recently decided to encode to ipod. Had the same issue with no mp4 file appearing, ran the patch and it seemed to have worked. However, when I watch the file (even on my mac) it crashes quicktime and vlc shows garbage then crashes too. I noticed that the log shows:

Starting ffmpeg.
processed: 83762 of 104821 frames at 96.50 fps (79.91%, eta: 3m 38s)
mythtranscode finished.
processed: 83809 of 104821 frames at 96.55 fps (79.95%, eta: 3m 37s)
ffmpeg finished.

So why is ffmpeg finishing before all frames have been processed? Any ideas??

Thanks a bunch!!

EDIT: ok. the lower number of frames is because of commercial cutting. So that's not the problem. Still, why does the encoded video crash both quicktime and vlc?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 08, 2010 12:03 am 
Offline
Joined: Fri Sep 07, 2007 11:57 pm
Posts: 166
Well. Here's some more info:

A zipped up mp4 file shouldn't be much smaller than the original. But when I zipped the file, it shrunk by a factor of 10. That means it's filled with empty space or repetitive garbage. Why??? What's going wrong with Encode for iPod? When I run it from the command line, I don't see any errors!

When I ran a "normal transcode" it made a file that was as big as the original (even when I choose low quality) and put it in the /myth/tv directory, not in /myth/videos/archive. It also deleted the original .mpg version of that file. The file that it created is in .nuv format. The .nuv file plays fine in mythtv and also plays in quicktime once I put it on my mac. The video is in Divx format and the audio is .mp3. I'm guessing all this is normal?

When I ran transcode for xvid, it took a very long time (over an hour for a 1 hour video) and resulted in a .avi file placed in /myth/videos/archive with the aspect ratio screwed up but otherwise perfectly playable in quicktime. The video is mpeg-4 and the audio is .mp3. Is this normal too?

In any case, it seems it is not the transcoder that is failing when encoding for iPod. What then???


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 08, 2010 10:33 am 
Offline
Joined: Wed Jan 04, 2006 10:20 am
Posts: 370
Location: South New Jersey, USA
Fra- I recently (post Christmas) got myth2ipod working on my 5.5 system by just doing the patch so it is possible. I don't do commercial cutting before transcoding. Have you tried that? Files work fine with vlc.

_________________
LINHES 8.3 BE/FE - MSI K9N6SGM-V with AMD A64 X2 4600+, 1GB Ram. 1.5TB WD. HDHR Prime & PVR150. Nvidia GT210. Silver remote.
FrontEnd - Dell Vostro 400 3.0GHz Core2Duo NVidia GeForce210. MCE Remote


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 08, 2010 12:42 pm 
Offline
Joined: Fri Sep 07, 2007 11:57 pm
Posts: 166
Big boy stan wrote:
Fra- I recently (post Christmas) got myth2ipod working on my 5.5 system by just doing the patch so it is possible. I don't do commercial cutting before transcoding. Have you tried that? Files work fine with vlc.


how can you make it not do the cutting? doesn't running Encode for iPod do the cutting automatically?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 08, 2010 3:25 pm 
Offline
Joined: Wed Jan 04, 2006 10:20 am
Posts: 370
Location: South New Jersey, USA
I guess I never noticed but you are right, all my ipod files have the commercials cut.
I will take a look at my log file tonight and see what is in there. Maybe it will help when compared to you.

_________________
LINHES 8.3 BE/FE - MSI K9N6SGM-V with AMD A64 X2 4600+, 1GB Ram. 1.5TB WD. HDHR Prime & PVR150. Nvidia GT210. Silver remote.
FrontEnd - Dell Vostro 400 3.0GHz Core2Duo NVidia GeForce210. MCE Remote


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 08, 2010 5:54 pm 
Offline
Joined: Fri Sep 07, 2007 11:57 pm
Posts: 166
actually, something interesting happened.

here's first the back story:
my friend (who has the 5.5) tried to rip dvd.
machine crashed and started giving errors about partition being full, at reboot.
i sshed and ran apt-get clean.
machine back to normal.
friend gave up on ripping dvds, since it wasn't crucial anyway.

then, he wanted to transcode for ipod so that he can watch shows while traveling.
so we had the above problem (i.e. first discovered a patch is needed, then it seemed to work but encoded file seems to be full of garbage!)

yesterday: machine crashed again and started showing the same errors about partition being full.
i sshed in and apt-get clean didn't help this time.
i poked around and found that /var/log/mythtv/mythwelcome.log is 2.5GB!!!!!

it seems it hasn't been rolling correctly!!!

i moved it to the other partition, and touched it (from mythtv as user)

now i'm waiting for my friend to get back home and turn the machine on.. crossing fingers.

my theory is that the dvd rip caused this and then apt-get clean didn't clean that part but freed up some space that got the machine going. and somehow the transcoding added to this and the machine crashed again.

maybe the dvd rip is the root of all these problems and now the machine will work fine and will transcode fine. we'll test that tonight and will report!

.... to be continued ....


Top
 Profile  
 
 Post subject: help PLEASE!
PostPosted: Mon Feb 08, 2010 9:07 pm 
Offline
Joined: Fri Sep 07, 2007 11:57 pm
Posts: 166
ok. still getting those errors about partition /var/lib/mysql being full!
i removed the huge file and /var actually only has 188M now!!!!
why is the box thinking the partition is full? is there a flag that was set and has not changed when i removed the offending file by hand?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 08, 2010 9:28 pm 
Offline
Joined: Fri Sep 07, 2007 11:57 pm
Posts: 166
actually, i only moved that big log file to another user. could it be that it is still on the smaller partition??? if so, then where should i move it? (i want to keep it for now, since it is a log file after all. i'll later move it away from the box and save it elsewhere. then i can delete)


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 09, 2010 12:32 am 
Offline
Joined: Fri Sep 07, 2007 11:57 pm
Posts: 166
ok.. i freaked out too soon.
i figured that if df -h shows the partitions and how full they are then
maybe df -h folder shows info about the folder. indeed. this way i figured
out that the user i moved the log file to was on that partition!!!!
so i moved the file to /myth/tmp and then shut the system down (using halt).
when restarted, it asked about the database name, which i got from that
same log file (mythcoverg) and the username and password (i guessed mythtv for both).
now things are back to normal.

i then tried to encode for ipod and it worked. so the patch was indeed enough and it was that stupid log file that caused the other encoding problems.

problem solved.

signing off!!


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 28 posts ] 
Go to page Previous  1, 2



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu