LinHES Forums

Mythvideo-scanner YET another imdb details grabber
Page 21 of 27

Author:  Too Many Secrets [ Sat Mar 13, 2010 10:22 pm ]
Post subject: 

bigB wrote:

How did you update? You don't appear to be running the latest...

The preferred method is to enter the directory that holds the source (untarred content of release file, or you can start off with just the makefile), then issue "make upgrade", followed by "make install". There is now more to the script than just "".

EG. Hold the installation source in /usr/local/src/mythvideo-scanner. This is where you execute the make commands. After installation, the script will live in /usr/local/bin/, and the modules will live in /usr/local/share/mythvideo-scanner/


Ozdemon, you try this on page 19?

Author:  Ozdemon [ Sun Mar 14, 2010 4:12 am ]
Post subject:  Install blues

After cd to /home/mythtv/mythvideo-scanner, terminal command as root:
make upgrade

which is answered with:

 Command not found

Author:  Too Many Secrets [ Sun Mar 14, 2010 11:00 am ]
Post subject: 

According to the above posted instructions, try this.

1. download or copy mythvideo-scanner tar file into /usr/local/src/
2. untar file tar tvfz file.tar.gz
3. cd /usr/local/src/mythvideo-scanner
4. make upgrade
5. make install

"After installation, the script will live in /usr/local/bin/, and the modules will live in /usr/local/share/mythvideo-scanner/"

Author:  bigB [ Sun Mar 14, 2010 4:27 pm ]
Post subject: 


The make process requires some extra programs, you can install these using:
pacman -S make subversion

Author:  Ozdemon [ Wed Mar 17, 2010 8:33 pm ]
Post subject:  Working now

Thanks bigB, all working now. Could I suggest adding the necessary steps to the first post in this thread, as well as the imbbpy install (p. 17 of this thread), so new users do not have to read the whole thread to get the script working.


Author:  bigB [ Wed Mar 17, 2010 9:22 pm ]
Post subject: 


I have just done this if anyone want to proof read it :-) Else, I'll fix it on a needs basis


Author:  Ozdemon [ Wed Mar 17, 2010 9:41 pm ]
Post subject: 

bigB wrote:

I have just done this if anyone want to proof read it :-) Else, I'll fix it on a needs basis


Looks good to my untutored eye. :)

Author:  Girkers [ Fri Mar 19, 2010 6:36 pm ]
Post subject: 

Hi bigB,

Just tried your instructions on the frontpage with a clean install of LinHES 6.02 and it didn't work quite as cleanly as I would have liked. Did the pacman thing easy enough, then with the easyinstall command it failed with not being able to install SQL Alchemy. I found another post that told me I had to run easyinstall again which I did and all was good again. (Might want to add this to the install instructions.

Then the rest of the install went fine but when I went to run it I found that I was missing a dependency. Running cpan Text::Levenshtein resolved the dependency problem, again you may want to add this to the install doco.

Now when I run it I get an error every now and then:
/usr/lib/python2.6/site-packages/MySQLdb/ DeprecationWarning: the sets module is deprecated
  from sets import ImmutableSet
/usr/lib/python2.6/site-packages/MythTV/ DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  self.message = message
Exception AttributeError: "'MythDB' object has no attribute 'db'" in <bound method MythDB.__del__ of <MythTV.MythDB.MythDB object at 0xb7710fcc>> ignored
Exception AttributeError: "'MythTV' object has no attribute 'socket'" in <bound method MythTV.__del__ of <MythTV.MythTV.MythTV object at 0xb79ea3ec>> ignored

I originally thought that it was something to do with my file names as I have [] in some for my reference only but I have seen it happen on normal named files as well.

I would like to thank you for efforts in creating this software it is a wonderful piece of kit and if there is any other information that you need to help you resolve these issues let me know.


Author:  raoul [ Sat Mar 27, 2010 12:43 pm ]
Post subject: 

Thanks BigB for the great script.

I am got it up and running on R6, but the curious thing is that the metadata doesn't seem to "take". I ran the script with the update and get pictures options, and while it was running, it looked like it was finding the shows...

But when I went back to my video folder the data that got downloaded didn't seemed to be linked to the shows. The cover images and screenshots were in the proper directories, but nothing showed when I navigated to the file(s).

I restarted the frontend with no change. I even rebooted and nothing.

So, I went in and manually did a "download metadata" from the "i" menu on an episode and R6 pulled in the info...

However, after manually going through my movies one at a time and getting the poster info and metadata through the frontend, a couple of hours later I went back into the video folder ... and *poof*, it was all gone.

I know the "download metadata" isn't part of your script, but I was wondering if the lack of metadata retention from your script and from the metadata download might be part of the same problem...

Author:  bigB [ Sun Mar 28, 2010 5:09 pm ]
Post subject: 


Are you using storage groups for your mythvideo files? My script currently does not support storage groups.

Do you have mythvideo-scanner set to run in a cron job (schedule) at all?

perhaps post the complete output for one file.


Author:  raoul [ Sun Mar 28, 2010 7:57 pm ]
Post subject: 

Ah, I think I found what it was. In the Service Menu->MythTV Configuration->Setup->Media Settings->Videos Settings->General I had to "Enable Metadata Brose Modes".

That seems to have fixed it.

And previously I had the episodes listed as "Castle - 103 HD - blahblah", and the regular "get metadata" didn't seem to figure out it was season 1 episode 3, but your script does a REALLY good job of it. :)


Author:  killabee444 [ Sat Apr 17, 2010 9:16 pm ]
Post subject:  The Pacific on HBO...


I am having a problem with an HBO miniseries called "The Pacific". It seems that it is always listed under my movies (should be TV), and also that mythvideo-scanner never gets the metadata correct (it gets metadata from an old movie called "south pacific" from the 40's), even though I have an .NFO file in the folder that contains the correct IMDB number.

Any thoughts? Thanks.

Author:  bigB [ Sun Apr 18, 2010 4:29 pm ]
Post subject: 


Can you post some output for me to look at, or atleast the filenames.


Author:  killabee444 [ Sun Apr 18, 2010 6:06 pm ]
Post subject: 

Here is one:

Band of Brothers 1x01 Currahee


Author:  bigB [ Sun Apr 18, 2010 10:41 pm ]
Post subject: 

Try the latest revision (97) of source.

Page 21 of 27 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group