LinHES Forums

no working video renderer available (xvmc-blit)
Page 1 of 1

Author:  Nightstranger [ Sat Nov 15, 2008 2:30 am ]
Post subject:  no working video renderer available (xvmc-blit)


I have installed Knoppmyth 5.5 on a Via Epia Me6000 Mainboard and I need to use the onboard chipset CLE266 for video acceleration.

I have also installed xserver packages of openchrome.
In my xorg.conf I start the driver in section "Device" with "openchrome"

This all works as I have a perfect working DVD-playback with Xine.

Unfortunately my Mythfrontend does not use the hw acceleration although I have tried different selection in the tv output configuration.

I have tried XvMC as well as Via-XvMC.

As video renderer there is xvmc-blit available but when I start whatching TV/recording I receive messages like

> VideoOutputXv: Desired video renderer 'xvmc-blit' not available.
> codec 'None' makes 'xv-blit,xshm,xlib,' available, using 'xv-blit' instead.

But the fall back renderer obviously do not support hw acceleration. (High CPU load, choppy video)

I did some research in the internet and I found that this might be an issue of the new in Mythtv version 0.21 (which I have installed)

    ~$ mythfrontend --version
    Please include all output in bug reports.
    MythTV Version : 17686M
    MythTV Branch : branches/release-0-21-fixes
    Library API : 0.21.20080304-1
    Network Protocol : 40
    Options compiled in:
    linux release using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_liv

My (urgent) questions:

- which renderer is the right one to pass video out through CLE266? When I tried any other renderer offered in the Mythtv settings, I received a very choppy video :-(

- how can I install Mythtv 0.20 instead?
- Do I need to recompile 0.21? But how?

Thanks for help


Author:  Nightstranger [ Thu Nov 03, 2011 4:19 pm ]
Post subject:  no working video renderer (xvmc-blit) - new attempt

Hello forum,

after a while I try again to get R5.5 working on my VIA Epia ME6000 Mainboard.

Again, I did a clean Auto Install and again I face similar problems like above.

When I start "watching TV" I see a black screen for a few seconds, then Mythfrontend crashes.

My settings in Mythfrontend configuration TV playback:

I added a new output profile with only one setting for all resolutions:

Decoder: VIA XvMC  #this sounds suitable for VIA CLE266 decoder#
Video Renderer: xvmc-blit  #nothing else selectable#

When I run Mythfrontend in a terminal, I receive those messages:
2011-11-03 21:56:29.871 Connecting to backend server: (try 1 of 5)
2011-11-03 21:56:29.876 Using protocol version 40
2011-11-03 21:56:29.899 TV: Attempting to change from None to WatchingLiveTV
2011-11-03 21:56:29.902 Using protocol version 40
2011-11-03 21:56:33.264 New DB connection, total: 3
2011-11-03 21:56:33.266 Connected to database 'mythconverg' at host:
2011-11-03 21:56:33.372 NVP: Disabling Audio, params(-1,2,44100)
2011-11-03 21:56:33.811 VideoOutputXv: Desired video renderer 'xvmc-blit' not available.
                        codec 'None' makes 'opengl,xv-blit,xshm,xlib,' available, using 'opengl' instead.
2011-11-03 21:56:34.480 GLVid, Error: Fatal error

here some lines of my xorg.conf (generated during installation):

Section "Device"
        ### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
        #Option     "sw_cursor"
        #Option     "hw_cursor"
        #Option     "NoAccel"
        #Option     "ShowCache"
        #Option     "ShadowFB"
        #Option     "UseFBDev"
        #Option     "Rotate"
        Identifier  "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
        Driver      "openchrome"
        VendorName  "All"
        BoardName   "All"
#       BusID       "PCI:1:0:0"

$lsmod | grep via
via                    43520  2
drm                    75668  3 via
snd_via82xx            26776  0
gameport               15240  1 snd_via82xx
snd_ac97_codec         99620  1 snd_via82xx
snd_pcm                70916  3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_page_alloc         11912  2 snd_via82xx,snd_pcm
snd_mpu401_uart        10880  1 snd_via82xx
i2c_viapro             11412  0
via_agp                12160  1
via_ircc               23572  0
agpgart                30808  2 drm,via_agp
i2c_core               23680  4 i2c_viapro,mt352,stv0299,b2c2_flexcop
snd                    52644  12 snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401_uart,snd_seq_dummy,snd_seq_oss,snd_seq,snd_timer,snd_rawmidi,snd_seq_device
irda                  122552  1 via_ircc

I have a fine playback of DVD with low CPU load using
xine -V xxmc dvd://
So HW acceleration through CLE266 seems to work.

here ... stcount=14 I found a posting with a similar problem. May I try this?

What else may I do?

Author:  cesman [ Thu Dec 22, 2011 3:06 am ]
Post subject: 

If I recall, it should just be "XvMC" not, "XvMC-blit". Did you get it resolved? I can install 5.5 on a system w/ a Unichrome chipset if it would help...

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group