View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 2 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Jun 04, 2009 8:27 am 
Offline
Joined: Wed Jul 25, 2007 7:56 pm
Posts: 103
Location: Arlington, VA, USA
Hi,

Is anyone else having issues with the pretty script? It stopped working for me about a month and a half ago, which IIRC is when I upgraded to the R6 preview.

If I try and run it directly, I get this:

Code:
[root@mythtv /]# /etc/cron.hourly/pretty
Net::UPnP::ControlPoint is not installed!
Please install Net::UPnP or copy ~/.mythtv/config.xml
from a working MythTV installation to /root/.mythtv/config.xml.
Compilation failed in require at /usr/share/mythtv/contrib/mythrename.pl line 22.
BEGIN failed--compilation aborted at /usr/share/mythtv/contrib/mythrename.pl line 22.
[root@mythtv /]#


I looked that up, and found other people having similar errors. The solution was to use CPAN to install Net::UPnP::ControlPoint AND Net::UPnP::QueryResponse, as described at the MythTV Wiki:

Quote:
Some users have been unable to use mythrename.pl without installing additional modules. The primary issue is Net::UPnP::ControlPoint? is not installed or an error that says something to that effect. Once Net::UPnP::ControlPoint is installed the error doesn't go away, as one must also install Net::UPnP::QueryResponse, as it is a prerequisite for UPnP::ControlPoint.

In gentoo and other linux distros you can install these by running "cpan" at a terminal, most likely as root. Answer the prompts that follow, then type "install Perl Net::UPnP::ControlPoint" at the cpan prompt and ALSO type "cpan> install Net::UPnP::QueryResponse", then run mythrename.pl either as a user with proper user:group permissions at a terminal or use the same command shown below as a "job" under mythtv-setup.


I tried doing this yesterday... but it seems my CPAN is unable to install either of these modules. I get several errors:

Code:
Warning: the following files are missing in your kit:
        lib/Net/UPnP/AV
Please inform the author.
Writing Makefile for Net::UPnP
Could not read '/root/.cpan/build/Net-UPnP-1.41-LaPPjU/META.yml'. Falling back to other methods to determine prerequisites
Can't exec "make": No such file or directory at /usr/share/perl5/core_perl/CPAN.pm line 7698.
  SKONNO/Net-UPnP-1.41.tar.gz
  make -- NOT OK
Warning (usually harmless): 'YAML' not installed, will not store persistent state
Running make test
  Can't test without successful make
Running make install
  Make had returned bad status, install seems impossible
Failed during this command:
 BMORROW/PerlInterp-0.05.tar.gz               : make NO
 SKONNO/Net-UPnP-1.41.tar.gz                  : make NO


I found a post from someone using MythDora with the same issue, but no solution. Any ideas?

EDIT:

Hm, perhaps I should have read the first error message more carefully. I copied over the config.xml to root's home, ran /etc/cron.hourly/pretty again, and it still gave the Net::UPnP::ControlPoint error, but the script ran and worked.

I guess this means my cron configuration is messed up somehow... not sure how, though. Root's crontab looks normal, and running the commands by themselves work fine... odd.

Code:
[root@mythtv pretty]# crontab -l root
#
# DO NOT EDIT THIS FILE MANUALLY!! USE crontab -e INSTEAD.
#

# <minute> <hour> <day> <month> <dow> <command>


01 * * * *  /usr/sbin/run-cron /etc/cron.hourly
02 00 * * * /usr/sbin/run-cron /etc/cron.daily
22 00 * * 0 /usr/sbin/run-cron /etc/cron.weekly
42 00 1 * * /usr/sbin/run-cron /etc/cron.monthly

[root@mythtv pretty]#


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jun 04, 2009 11:16 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Please open a flyspray ticket if there isn't already one there.

BTW - There is: FS#303


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu