View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject: No "make" program in R6?
PostPosted: Fri Jun 19, 2009 11:38 pm 
Offline
Joined: Sun May 29, 2005 5:47 pm
Posts: 65
Hi all,

I was just playing around with R6 on some new hardware for a HD mythtv box and was trying to compile the latest alsa drivers from scratch. Unfortunately, I was stymied because the program "make" is no where to be found. Was this intentional? Perhaps, but I woudl be surprised. I need to compile the latest alsa drivers to get digital audio working on my new motherboard, ASUS P5N7A-VM. I actually went back and did a fresh install for R6 to be sure that I hadn't deleted make by mistake.

Should I enter the absence of "make" in flyspray?

Thanks


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 19, 2009 11:51 pm 
Offline
Joined: Sun Sep 25, 2005 3:50 pm
Posts: 1013
Location: Los Angeles
Code:
$ sudo pacman -Sy base-devel
should get you set up with the development tools you need to compile your driver. After confirming your shiny new ALSA driver works, you can submit a "Feature Request" ticket to flyspray for an updated version of ALSA.

You may find the ABS Arch Wiki entry helpful as well.

_________________
Mike
My Hardware Profile


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 20, 2009 7:09 am 
Offline
Joined: Sun May 29, 2005 5:47 pm
Posts: 65
Mike,

Great link! Thank you!

I was wondering if any one was willing to share their configuration files for ABS. I would imagine that everyone building R6 packages would have a nearly identical set of ABS files. Reading the wiki it looks you have to edit two files:

nano /etc/abs.conf
nano /home/mythtv/abs/slim/PKGBUILD

It may be no big deal to edit these directly and perhaps there is not much to edit, but it always handy to start from a configuration that is known to work the target appliance.

If I get this working, I will be happy to share my package and experience.

I have not had digital audio working properly (pass through) on a myth system since R5C7. The audio drivers for my 7NIF4 never quite worked completely with ALSA and I couldn't build OSS drivers past R5C7. I'm looking forward to getting this working on my new board.

-Mark


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu