View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 8 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Wed Jul 01, 2009 9:10 pm 
Offline
Joined: Tue Mar 22, 2005 9:18 pm
Posts: 1392
Location: Brisbane, Queensland, Australia
I am having a problem whereby when I try to delete a recording, it disappears from the screen and a moment or two later it comes back. It is only some recordings and they appear to be ones that I had watched on my separate frontend, if that makes a difference.

It is like the files are locked for some reason. After trying to delete them and they come back, you can still watch them, so the files themselves are intact.

Can anyone suggest a way for me to get rid of the recordings so that they are gone for good, not just for a few seconds?

_________________
Girkers


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 02, 2009 9:35 am 
Offline
Joined: Mon Oct 09, 2006 11:27 am
Posts: 75
Location: Raleigh, NC
If you're running R6, there was an issue with the backend running as root, making the recordings owned by root.

There is a fix in the repo's now, or you can search flyspray for the issue of of "recordings owned by root," and see my comment for a fix


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 05, 2009 5:51 pm 
Offline
Joined: Sun Sep 04, 2005 7:48 pm
Posts: 264
Location: Perth, Australia
I have this problem now, as a result of a recent pacman upgrade.
I havent tried the fix yet (at work), but for those that find the flyspray search interface a little challenging (like me)..

http://linhes.org/flyspray/index.php?do=details&task_id=248

Sounds like it will do the job.

Nathan

_________________
LinHES: R6 | MB: Asus M3N-H/HDMI | CPU: AMD ??Mhz
Capture: 2xHDHR DVB-T
Graphics: Onboard 8300|PSU: Corsair vx450w
Cooling: Zalman cu?,
Display: Benq xx projector


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 05, 2009 6:16 pm 
Offline
Joined: Mon Oct 09, 2006 11:27 am
Posts: 75
Location: Raleigh, NC
thanks nmcaullay ... it would have been more helpful if I had linked to the ticket.

The fix will take care of future recordings, but you'll still need to reset the owner on the existing recordings. You'll need to do it as root (or using sudo from the mythtv user):

**edit I had user:group wrong ... should be mythtv. fixed below **

Code:
sudo chown mythtv:mythtv /myth/tv/*


Also, I did confirm that the fix came with a pacman update, so everyone might want to try that before going through all the steps:

Code:
sudo pacman -Syu


You can confirm the fix is in the update by viewing that same file called out on the ticket (/etc/sv/mythbackend/run) and confirming the backend it being started as the mythtv user.


Last edited by craigtv on Sat Jul 18, 2009 12:52 pm, edited 1 time in total.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 05, 2009 6:47 pm 
Offline
Joined: Sun Sep 04, 2005 7:48 pm
Posts: 264
Location: Perth, Australia
hey craigtv,

thanks for that, it saves me fumbling around google trying to find the syntax :)

as for the fix in the repos, i upgraded only a couple of days ago, and this problem appeared after that... so I assumed that the upgrade introduced the problem, rather than containing a fix...

it will be interesting to see what i have in those files...

Cheers,

Nathan

_________________
LinHES: R6 | MB: Asus M3N-H/HDMI | CPU: AMD ??Mhz
Capture: 2xHDHR DVB-T
Graphics: Onboard 8300|PSU: Corsair vx450w
Cooling: Zalman cu?,
Display: Benq xx projector


Top
 Profile  
 
PostPosted: Sat Jul 18, 2009 12:30 pm 
Offline
Joined: Wed Nov 09, 2005 1:21 pm
Posts: 161
Location: Manchester UK
The Bugs still there just done a pacman upgrade

sudo chown myth:myth /myth/tv/*

didn't work for me

but tried this below and got it working

Code:
> sudo chown myth:myth /myth/tv/*
chown: invalid user: `myth:myth'
> sudo chown mythtv:mythtv /myth/tv/*

_________________
Running:-
Intel 930 3GHz dual Core
Thermaltake Fanless CPU Cooler
Asus P5GS
Samsung 750G Sata HDD
8400 512m Video Card
2 * jetway DVB-t
1 * Haupage DVB-S2 Card
Samsung Sata 16x DVDRW
2048M Ram
1 * Netop Ion 330


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jul 18, 2009 12:54 pm 
Offline
Joined: Mon Oct 09, 2006 11:27 am
Posts: 75
Location: Raleigh, NC
Sorry about that ... user and group should be mythtv as simonf pointed out. I edited my original post to correct the command.

Craig


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 26, 2009 6:20 am 
Offline
Joined: Tue Mar 22, 2005 9:18 pm
Posts: 1392
Location: Brisbane, Queensland, Australia
Just to clarify I did work this out just yesterday and everyone is right, the recordings were owned by root. I just chown them all and I was then able to delete them.

_________________
Girkers


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu