LinHES Forums

Can't delete some recordings
Page 1 of 1

Author:  Girkers [ Wed Jul 01, 2009 9:10 pm ]
Post subject:  Can't delete some recordings

I am having a problem whereby when I try to delete a recording, it disappears from the screen and a moment or two later it comes back. It is only some recordings and they appear to be ones that I had watched on my separate frontend, if that makes a difference.

It is like the files are locked for some reason. After trying to delete them and they come back, you can still watch them, so the files themselves are intact.

Can anyone suggest a way for me to get rid of the recordings so that they are gone for good, not just for a few seconds?

Author:  craigtv [ Thu Jul 02, 2009 9:35 am ]
Post subject: 

If you're running R6, there was an issue with the backend running as root, making the recordings owned by root.

There is a fix in the repo's now, or you can search flyspray for the issue of of "recordings owned by root," and see my comment for a fix

Author:  nmcaullay [ Sun Jul 05, 2009 5:51 pm ]
Post subject: 

I have this problem now, as a result of a recent pacman upgrade.
I havent tried the fix yet (at work), but for those that find the flyspray search interface a little challenging (like me)..

Sounds like it will do the job.


Author:  craigtv [ Sun Jul 05, 2009 6:16 pm ]
Post subject: 

thanks nmcaullay ... it would have been more helpful if I had linked to the ticket.

The fix will take care of future recordings, but you'll still need to reset the owner on the existing recordings. You'll need to do it as root (or using sudo from the mythtv user):

**edit I had user:group wrong ... should be mythtv. fixed below **

sudo chown mythtv:mythtv /myth/tv/*

Also, I did confirm that the fix came with a pacman update, so everyone might want to try that before going through all the steps:

sudo pacman -Syu

You can confirm the fix is in the update by viewing that same file called out on the ticket (/etc/sv/mythbackend/run) and confirming the backend it being started as the mythtv user.

Author:  nmcaullay [ Sun Jul 05, 2009 6:47 pm ]
Post subject: 

hey craigtv,

thanks for that, it saves me fumbling around google trying to find the syntax :)

as for the fix in the repos, i upgraded only a couple of days ago, and this problem appeared after that... so I assumed that the upgrade introduced the problem, rather than containing a fix...

it will be interesting to see what i have in those files...



Author:  simonf [ Sat Jul 18, 2009 12:30 pm ]
Post subject:  The Bugs still there just done a pacman upgrade

The Bugs still there just done a pacman upgrade

sudo chown myth:myth /myth/tv/*

didn't work for me

but tried this below and got it working

> sudo chown myth:myth /myth/tv/*
chown: invalid user: `myth:myth'
> sudo chown mythtv:mythtv /myth/tv/*

Author:  craigtv [ Sat Jul 18, 2009 12:54 pm ]
Post subject: 

Sorry about that ... user and group should be mythtv as simonf pointed out. I edited my original post to correct the command.


Author:  Girkers [ Sun Jul 26, 2009 6:20 am ]
Post subject: 

Just to clarify I did work this out just yesterday and everyone is right, the recordings were owned by root. I just chown them all and I was then able to delete them.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group