View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Feb 01, 2007 7:31 pm 
Offline
Joined: Sun Oct 30, 2005 5:59 pm
Posts: 2
Over the last 3 days I have been working on my R5A26 upgrade to R5E50. Throughout the process the KnoppMyth forum and wiki have been invaluable. With that said, I ran into a few problems that were not discussed and I want to contribute back. Most likely the problems were due to my own noobieism – but I figured there may be some value in this for others.

# Video type: SDTV
# Type of system: combined front- and back-end
# Noise level: I can tell it's on until I play some media

# CASE: Cavalier Cooler Master
# PSU: Proprietary Cooler Master
# MOTHERBOARD: Unknown
# CPU: PIII 1GHz
# RAM: 768 M
# CPU HEATSINK: Unknown
# NORTHBRIDGE HEATSINK: Unknown
# CD/DVD-RW: Matsushita DVD-RW
# HDD: 1x200G Seagate & 1x250G Seagate IDE
# GRAPHICS CARD: Nvidia
# SOUNDCARD: Cheap POC
# TUNER CARD: PVR350
# REMOTE CONTROL: PVR350 Grey

Problem #1: Mythbackend would not start – error: No BackendIP address defined in mythtv-setup

I ran into the issue where upgrading from builds of KnoppMyth prior to R5C7 the capture card definitions will not translate. Using the CompileIvtv page on the Wiki I found the link in step 11 for GettingBackIntoMythTVSetup. Unfortunately neither of these helped for the following reasons:
1. Using Alt S and Alt M had no effect. Everytime I exited out of Mythfrontend it would restart X and load the frontend again.
2. The second method export DISPLAY=:0 had no effect either.

The solution I finally found after much hunting was in the /home/mythtv/.xsession file. This file contains one line:
Code:
/usr/bin/mythfrontend

My first attempt was simply to comment out this line – which had the effect of not allowing X to start at all. Finally I replaced
Code:
/usr/bin/mythfrontend
with
Code:
/usr/bin/mythtv-setup
and rebooted the box. This had the desired effect, and I deleted all capture cards and rebuilt everything – and finally the backend would start.

NOTE: If doing the above, you need to return the .xsession file to /usr/bin/mythfrontend

Problem #2: setup_350.sh script would not setup TVout on my PVR350.
Prior to upgrading, I had used an earlier version of this script with no problems to reconfig the TVout on my R5A26 box. For some reason this time it was not working.

Turns out that my XF86Config-4 file was gone. I unzipped / untarred the backup (which I had done in addition to mythbackup, as stated in the R5E50 Upgrade hints and hazards and found the original – hoping it would work (no luck). After looking through the error logs I found a line saying “device /dev/ cannot be initialized�. Sure enough, my xorg.conf file was missing fb1 in the device section. The CompileIvtv page again helped me find this problem.

After that it was smooth sailing. 2.5 days of spare time to get the main box running – but 20 minutes to upgrade my standalone frontend!

Thanks to Cecil, tjc, xsecrets and everyone that contributes to the KnoppMyth community. You guys do a great job!

Sean…


Last edited by sean3522 on Fri Feb 02, 2007 6:55 pm, edited 1 time in total.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 01, 2007 7:54 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
#1 - Looks like the restore of /home/mythtv may have brought back some odd stuff. Although I'm not quite sure what. I don't have a .xsession file. Deleting it may have helped. The .fluxbox config should have started up KnoppMyth-run for you.

#2 - Because of the switch to the xorg server XF86Config-4 is no longer used.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 01, 2007 9:37 pm 
Offline
Joined: Sun Oct 30, 2005 5:59 pm
Posts: 2
tjc,

In regards to #1, the .xsessions file is hidden on my box. See below:
Code:
root@mythtv:/home/mythtv# ls -A -l .xsession
-rw-r--r-- 1 mythtv mythtv 24 Jan 31 13:18 .xsession
root@mythtv:/home/mythtv# cat .xsession
 /usr/bin/mythfrontend


I actually tried renaming .xsession to .xsession.old and it had the same effect as trying to comment out the line (X would not boot). As for .fluxbox config I looked in there too and tried to comment out the KnoppMyth-run as I figured that was partially my problem of not being able to run mythtv-setup. Can't remember exactly what happened when I did that, but it wasnt helping me.

As for #2, that makes sense. My solution ultimately was in that config file. The strange thing there is the setup_350.sh put in the correct hw address, but not the frame buffer.

Regardless, I am glad it's behind me. Thanks again.

Sean...


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu