View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 11 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Sep 03, 2007 2:03 pm 
Offline
Joined: Sun Sep 02, 2007 2:30 pm
Posts: 94
Hi,

I have a hauppauge NOVA-T 500 card of the dual dvb-t tuner variety running on R5F1. I have read on the internet that an upgrade of the linux firmware for this card will get the remote control working (which was previously unsupported).

To upgrade the latest firmware I had to do the following:
1. Press <ctrl> <alt> <del> <F2> to bring up the command prompt
2. Then enter the following:
Code:
apt-get update

[this brings up an error about a key, make a note of this key then...]
Code:
gpg --keyserver pgp.mit.edu --recv-keys [enter the key here]
gpg --armor --export [enter the last 6 digits of the key here] | apt-key add -
apt-get update
apt-get install mercurial
cd ~
hg clone http://linuxtv.org/hg/v4l-dvb
cd v4l-dvb
make
make install
wget http://www.wi-bw.tfh-wildau.de/~pboettch/home/linux-dvb-firmware/dvb-usb-dib0700-03-pre1.fw
cd v4l-dvb [not quite sure why it required entering again but only way to work for me...]
cp dvb-usb-dib0700-03-pre1.fw /lib/firmware
cp dvb-usb-dib0700-03-pre1.fw /usr/lib/hotplug/firmware

3. Then switch on the card's on-board amplifiers (really needed to get a good signal strength)
Code:
cd /etc/modprobe.d
echo "options dvb-usb-dib0700 force_lna_activation=1" > dvb-usb-dib0700
echo "options dvb-usb-dib0700 force_lna_activation=1" > video4linux
echo "options dvb-usb-dib0700 force_lna_activation=1" > options

I entered this in many files because I wasn't sure which on knoppmyth reads, however for me at least it appears to work.
4. Restart the computer
Code:
reboot


However this is as far as I've got. If you enter:
Code:
dmesg | grep dvb
and
Code:
 dmesg | grep DVB
all appears fine and the infra-red receiver is registered (by DVB). Pressing a few buttons on the remote returns an unindentified command error. I know that a lircd.conf file is required and I've found the following:
Code:
#
# brand:                       Hauppauge NOVA-T-500
# model no. of remote control: Hauppage Nova-T-500 Snowboard Shape Silver over Black
#

begin remote

 name  NOVA-T500
 bits           16
 eps            30
 aeps          100

 one             0     0
 zero            0     0
 pre_data_bits   16
 pre_data       0x1
 gap          199999
 toggle_bit      0


     begin codes
         Go                       0x0162
         Power                    0x0074
         TV                       0x0179
         Videos                   0x0189
         Music                    0x0188
         Pictures                 0x00E2
         Guide                    0x016D
         Radio                    0x0181
         ArrowUp                  0x0067
         ArrowLeft                0x0069
         OK                       0x0160
         ArrowRight               0x006A
         ArrowDown                0x006C
         BackExit                 0x009E
         Menu                     0x008B
         VolumeUp                 0x0073
         VolumeDown               0x0072
         PrevCh                   0x016B
         Mute                     0x0071
         ChannelUp                0x0192
         ChannelDown              0x0193
         Record                   0x00A7
         Rewind                   0x00A8
         SkipBack                 0x0195
         Play                     0x00CF
         Pause                    0x0077
         Stop                     0x0080
         Fwdwind                  0x00D0
         SkipFwd                  0x0197
         1                        0x0002
         2                        0x0003
         3                        0x0004
         4                        0x0005
         5                        0x0006
         6                        0x0007
         7                        0x0008
         8                        0x0009
         9                        0x000A
         Star                     0x0037
         0                        0x000B
         #                        0x0029
         Red                      0x018E
         Green                    0x018F
         Yellow                   0x0190
         Blue                     0x0191
     end codes

end remote

I saved this in the folder /etc/lirc but this still doesn't work. Has any got the remote to work yet?

The following sites are useful:
http://www.mythtv.org/wiki/index.php/Ha ... -T_500_PCI
http://www.knoppmythwiki.org/index.php?page=NovaT500


Last edited by mythman13 on Fri Dec 31, 2010 9:41 am, edited 3 times in total.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 04, 2007 3:48 am 
Offline
Joined: Sun Jun 12, 2005 2:39 pm
Posts: 464
Location: UK
Have you looked how to setup the Nova-T remote? They could be similar. If you paste the output of:

cat /proc/bus/input/devices

I can tell you if the Nova-T method will work


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 04, 2007 8:20 am 
Offline
Joined: Sun Sep 02, 2007 2:30 pm
Posts: 94
cat /proc/bus/input/devices gave me this:

Code:
I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 Keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input0
H: Handlers=kbd event0
B: EV=120013
B: KEY=4 2000000 3802078 f840d001 feffffdf ffdfffff ffffffff fffffffe
B: MSC=10
B: LED=7

I: Bus=003 Vendor=2040 Product=9950 Version=0100
N: Name="IR-receiver inside USB DVB receiver"
P: Phys=usb-0000:05:04.2-1/ir0
S: Sysfs=/class/input/input1
H: Handlers=kbd event1
B: EV=3
B: KEY=10afc332 2842845 0 0 0 4 80018000 2180 40000801 9e96c0 0 800200 ffc


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 04, 2007 8:29 am 
Offline
Joined: Sun Jun 12, 2005 2:39 pm
Posts: 464
Location: UK
Yep it looks just like what mine says with a normal Nova-T!

Try setting /etc/lircd/hardware.conf to look just like this:

Code:
#Arguments which will be used when launching lircd
LIRCD_ARGS=""

#Don't start lircmd even if there seems to be a good config file
START_LIRCMD=false

#Try to load appropriate kernel modules
LOAD_MODULES=false

# Run "lircd --driver=help" for a list of supported drivers.
DRIVER="dev/input"
# If DEVICE is set to /dev/lirc and devfs is in use /dev/lirc/0 will be
# automatically used instead
DEVICE="/dev/input/event1"
MODULES="lirc_dev lirc_i2c"


Reboot (lirc is crap and only seems to pick up changes after a reboot)
And test lirc by opening a command prompt and run: irw
press some buttons on the remote and it should tell you the key you pressed.


Top
 Profile  
 
 Post subject: update
PostPosted: Tue Sep 04, 2007 8:44 am 
Offline
Joined: Sun Sep 02, 2007 2:30 pm
Posts: 94
UPDATE:

I've managed to get the remote sought of working BUT only the arrow and number keys work.

However if I run irw I get all the keys displaying on the test - it is only in mythtv that it doesn't seem to work properly.

irw gave this sought of output for ALL the keys:
Code:
000000000001016b 00 PrevCh NOVA-T500
000000000001006a 00 ArrowRight NOVA-T500
0000000000010192 00 ChannelUp NOVA-T500
0000000000010074 00 Power NOVA-T500
0000000000010160 00 OK NOVA-T500
0000000000010071 00 Mute NOVA-T500
0000000000010192 00 ChannelUp NOVA-T500
000000000001006a 00 ArrowRight NOVA-T500
0000000000010067 00 ArrowUp NOVA-T500
0000000000010069 00 ArrowLeft NOVA-T500
000000000001006c 00 ArrowDown NOVA-T500


What I did:

I reinstalled lirc according to http://www.knoppmythwiki.org/index.php?page=LIRCHowTo then I copied the above lircd.conf file to /etc/lirc/lircd.conf and edited the /etc/lirc/hardware.conf to the following according to http://www.mythtv.org/wiki/index.php/Ha ... -T_500_PCI

Code:
# /etc/lirc/hardware.conf
#
# Arguments which will be used when launching lircd
LIRCD_ARGS=""

#Don't start lircmd even if there seems to be a good config file
#START_LIRCMD=false

#Try to load appropriate kernel modules
LOAD_MODULES=true

# Run "lircd --driver=help" for a list of supported drivers.
DRIVER="dev/input"
# If DEVICE is set to /dev/lirc and devfs is in use /dev/lirc/0 will be
# automatically used instead
DEVICE="/dev/lirc0"
MODULES=""

# Default configuration files for your hardware if any
LIRCD_CONF="/etc/lirc/lircd.conf"
LIRCMD_CONF=""


I then put the the following lircrc file in the locations:
/etc/ -- to give /etc/lircrc with the file, and
/home/mythtv.mythtv -- to give /home/mythtv/.mythtv/lircrc with the file

Code:
# /etc/lircrc
# ln ~mythtv/.mythtv/lircrc
#
# MythTV native LIRC config file for
# Hauppage Nova-T-500 PCI Dual Tuners DVB-T
# Snowboard shape remote
# Silver on top Black underneath
# 45 buttons
#
# Originally
# By Jarod Wilson, 2003/12/21
# Amalgamated from Jeff Campbell's .lircrc



################## MythTV Control ######################
### http://www.mythtv.org/wiki/index.php/Keybindings ###

#   Remote Button
##   MythTV function


#   Go
##   Go to home page
begin
prog = mythtv
button = Go
config = ALT+H
end

#   Power
##   Turns monitor in Standby
begin
prog = irexec
button = Power
config = sudo vbetool dpms on ; sudo vbetool dpms off
end

#   TV
##   Go to Watch TV
begin
prog = mythtv
button = TV
config = ALT+T
end

#   Videos
##   Go to MythVideo
begin
prog = mythtv
button = Videos
config = ALT+V
end

#   Music
##   Go to MythMusic
begin
prog = mythtv
button = Music
config = ALT+M
end

#   Pictures
##   Go to MythGallery
begin
prog = mythtv
button = Pictures
config = ALT+P
end

#   Guide
##   display EPG
begin
prog = mythtv
button = Guide
config = s
end

#   Radio



#   ArrowUp
##   Up
begin
prog = mythtv
button = ArrowUp
config = Up
end

#   ArrowLeft
##   Left
begin
prog = mythtv
button = ArrowLeft
config = Left
end

#   OK
##   Select/enter/resolve
begin
prog = mythtv
button = OK
config = Space
end

#   ArrowRight
##   Right
begin
prog = mythtv
button = ArrowRight
config = Right
end

#   ArrowDown
##   Down
begin
prog = mythtv
button = ArrowDown
config = Down
end

#   BackExit
##   Exit/go back/cancel
begin
prog = mythtv
button = BackExit
config = Esc
end

#   Menu
##   Menu
begin
prog = mythtv
button = Menu
config = m
end

#   VolumeUp
##   Volume Up
begin
prog = mythtv
button = VolumeUp
config = F11
end

#   VolumeDown
##   Volume down
begin
prog = mythtv
button = VolumeDown
config = F10
end

#   PrevCh
##   Change tuner card input
begin
prog = mythtv
button = PrevCh
config = c
end

#   Mute
##   Mute
begin
prog = mythtv
button = Mute
config = F9
end

#   ChannelUp
begin
prog = mythtv
button = ChannelUp
config = Up
end

#   ChannelDown
begin
prog = mythtv
button = ChannelDown
config = Down
end

#   Record
begin
prog = mythtv
button = Record
config = R
end

#   Rewind
begin
prog = mythtv
button = Rewind
config = Left
end

#   SkipBack
begin
prog = mythtv
button = SkipBack
config = PgUp
end

#   Play
begin
prog = mythtv
button = Play
config = Return
end

#   Pause
begin
prog = mythtv
button = Pause
config = P
end

#   Stop
begin
prog = mythtv
button = Stop
config = Esc
end

#   Fwdwind
begin
prog = mythtv
button = Fwdwind
config = Right
end

#   SkipFwd
begin
prog = mythtv
button = SkipFwd
config = PgDown
end

#   1
begin
prog = mythtv
button = 1
config = 1
end

#   2
begin
prog = mythtv
button = 2
config = 2
end

#   3
begin
prog = mythtv
button = 3
config = 3
end

#   4
begin
prog = mythtv
button = 4
config = 4
end

#   5
begin
prog = mythtv
button = 5
config = 5
end

#   6
begin
prog = mythtv
button = 6
config = 6
end

#   7
begin
prog = mythtv
button = 7
config = 7
end

#   8
begin
prog = mythtv
button = 8
config = 8
end

#   9
begin
prog = mythtv
button = 9
config = 9
end

#   Star
##   Info
begin
prog = mythtv
button = Star
config = i
end

#   0
begin
prog = mythtv
button = 0
config = 0
end

#   #
##   Toggle recording of current program (cycles through types)
begin
prog = mythtv
button = #
config = r
end

#   Red
##   Picture zoom
begin
prog = mythtv
button = Red
config = W
end

#   Green
#   OSD navigation through channels/programs
begin
prog = mythtv
button = Green
config = O
end

#   Yellow
begin
prog = mythtv
button = Yellow
config = Q
end

#   Blue
begin
prog = mythtv
button = Blue
config = Z
end


In despiration I also put a copy:
~/.lircrc and
/etc/lirc/

I then restarted the computer but only the arrow and number buttons worked?

If I removed all these files the remote didn't work on myth at all - so it must be something to do with these files, but I've checked and all the commands seem to alright (except some of those pointing to F keys I think like the volume) am I missing something?


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 04, 2007 8:56 am 
Offline
Joined: Sun Jun 12, 2005 2:39 pm
Posts: 464
Location: UK
in hardware.conf, the line:
DEVICE="/dev/lirc0"

needs to be

DEVICE="/dev/input/event1"

If that doesnt work, try setting LOAD_MODULES to false

After any change, reboot and test it in mythtv first


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 04, 2007 11:51 am 
Offline
Joined: Sun Sep 02, 2007 2:30 pm
Posts: 94
Hi, yeah thanks for this (sorry I posted the last post before reading your's!).

I have made the changes you suggested to the hardware.conf file (mine is now idnetical to yours) and rebooted the machine but still only theses keys work:

Arrow up, arrow right, arrow down, arrow left, 1, 2, 3, 4, 5, 6, 7, 8, 9, 0, *

What's perculiar is that when I press * it says See and a sought of half downward arrow head after it on the screen where the channel numbers appear. I've edited the lircrc file above so that * = F6 which allows exiting of the red button stuff. I cannot find a comparible button on the keyboard which brings up See?! Btw I'm testing this whilst watching pre-recorded video not live tv, but this shouldn't make a difference....


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 05, 2007 2:33 am 
Offline
Joined: Sun Jun 12, 2005 2:39 pm
Posts: 464
Location: UK
The reason some of the keys work is because the remote is treated as a normal input device (like a keyboard). Lirc is supposed to grab the input so that all the keys work.

If you run irw does it still display what key you press for all the keys?

Also, run cat /proc/bus/input/devices again and check which event is listed under N: Name="IR-receiver inside USB DVB receiver"

Sometimes they change which causes problems.


Top
 Profile  
 
 Post subject: It WORKS!!!
PostPosted: Fri Sep 07, 2007 1:34 pm 
Offline
Joined: Sun Sep 02, 2007 2:30 pm
Posts: 94
Hi,

Thanks for your help - I've got it working fully now!

I had to rebuild the pc and I think this fixed it - I reckon that because I initially re-insalled lirc (not really sure why now but I was following the how-to guide on knoppmythwiki) and I think this didn't install properly. Anyway after I re-built the pc it still had the same problem despite all the configuration being the same as above. I then realised that perhaps this was because I was copying the files from the windows pc - I created the files using Notepad on Windows, then put them on my intranet webserver to download them to my knoppmyth box. Consequently I think they were in DOS format and perhaps knoppmyth couldn't read this so I ran dos2unix on them. I then rebooted the pc but this time it said "unknown remote control key" I rebooted but still it wasn't fixed. I gave up and switched off -completely- the pc. When I switched it on again it worked perfectly! However on a couple of occasions it still didn't work. I since realised that this was possibly because I was altering my tv settings with my different tv remote. Knoppmyth picked this up with an unknown remote control key. If I didn't touch my tv remote during boot the remote worked perfectly once booted and in conjunction with my tv remote with apparently no problems.

So my advice to owners of Knoppmyth R5F1 and a NOVA-T 500:
1. When first installing knoppmyth select "other remote" on the remote setup screen.
2. Download mercurial, v4l-dvb and the latest card firmware as I did above.
3. Copy the lircd.conf to /etc/lirc and the lircrc file to /home/mythtv/.mythtv and /etc/ and to ~/ renaming it .lircrc for this folder only.
4. Edit the hardware.conf file with nano to madpaddler's above although only the driver line I've found is really essential and I had to add a line to lircd.conf file: LIRCD_CONF=/etc/lircd.conf" --I think
5. Run dos2unix on these files if you downloaded it from a windows system.
6. Make sure you haven't duplicated files and that the lircd.conf file really is the one you want (I had to delete old ones first before copying my new one).
7. Power off your pc fully and then switch it on again.
8. Hopefully it should work!

Also I did all this using root. If I changed the lircrc file with root using nano and saved it the permissions went mad can I do something to allow all users to read it?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 07, 2007 5:40 pm 
Offline
Joined: Tue Mar 22, 2005 9:18 pm
Posts: 1371
Location: Brisbane, Queensland, Australia
Just a tip for the future, use WordPad on Windoze to edit your files as this will save them in the proper text format with the right carriage returns and stuff.

_________________
Girkers


Top
 Profile  
 
 Post subject: R5F27 advice
PostPosted: Tue Sep 18, 2007 11:09 am 
Offline
Joined: Sun Sep 02, 2007 2:30 pm
Posts: 94
Hi I've just upgraded (as a clean install) from R5F1 to R5F27 as it has just been released. Unlike with R5F1 the NOVA-T 500 card does NOT work straight after the install without some 'tweaking'.

Running:
Code:
dmesg | grep dvb
dmesg | grep DVB

Suggests that computer is looking for the latest firmware for the card (dvb-usb-dib0700-03-pre1.fw) but it is missing off the harddrive and therefore NOT bundled with the installation package. Instead only the old firmware is bundled (dvb-usb-dib0700-01.fw) but it dosen't load this by default.

To get it working simply download the latest firmware as above:
Code:
wget http://www.wi-bw.tfh-wildau.de/~pboettch/home/linux-dvb-firmware/dvb-usb-dib0700-03-pre1.fw
cp dvb-usb-dib0700-03-pre1.fw /lib/firmware
cp dvb-usb-dib0700-03-pre1.fw /usr/lib/hotplug/firmware

and then add the amplifier settings into the relavent files:
Code:
cd /etc/modprobe.d
echo "options dvb-usb-dib0700 force_lna_activation=1" > dvb-usb-dib0700
echo "options dvb-usb-dib0700 force_lna_activation=1" > video4linux
echo "options dvb-usb-dib0700 force_lna_activation=1" > options

Switch off the computer fully and then switch on again.

The firmware should then be loaded properly and the card should work in myhTV. (Run the dmesg commands to check). Do the above to get the remote control working. I did not bother with installing mercurial, the apt-get update or the v4l-dvb with R5F27 and it works okay - I just did the above and my card worked. Do this before you run the mythTV setup by pressing <ctrl> <alt> <F1>, logging in as root and running the above immediately after the computer first boots after the initial Knoppmyth install.

Please could anyone who knows how ask to get the latest firmware included with this release to make life easier in the future! Thanks.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu