View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Tue Sep 11, 2007 1:41 am 
Offline
Joined: Sun Mar 05, 2006 11:27 am
Posts: 44
Location: Edinburgh, Scotland
One of the known issues with the setup of tvout on this card is that for some reason the frame buffer can be assigned a different device on the initial install to the one it is assigned after a reboot. This means that the installer may have put the wrong device for the framebuffer into the /etc/X11/xorg.conf file. This is not new in this release and has been documented already elsewhere, but as this is the only configuration required with tvout on R5F27 I thought it worth reiterating in this context.

The symptoms of this are that although tvout worked during install, after a reboot the console goes to the tv, but xwindows fails to start with a respawn message.

The fix is to examine the devices and update xorg.conf to point to the device that is actually created for the frame buffer now that there has been a reboot.

Press return to get to a login prompt and login as root.

First identify the actual frame buffer device that is in use
Code:
cat /proc/fb

This should produce a list of frame buffers available something like

root@mythtvtest2:/# cat /proc/fb
0 cx23415 TV out

In this case there is only one frame buffer and it is named /dev/fb0
If there is more than one framebuffer you may have to determine which is the pvr350 tvout frame buffer - hopefully it will be obvious.

Keep a copy of the current xorg.conf file
Code:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.350.orig

edit the configuration file using your favourite editor eg
Code:
nano /etc/X11/xorg.conf

and look for the line that looks something like
Code:
Option          "fbdev" "/dev/fb1"

Make sure the device listed on this line matches that found earlier.

In my case it needed to be changed to
Code:
Option          "fbdev" "/dev/fb0"

save the file and
Code:
reboot

If this was the only problem then Xwindows will startup properly.


Top
 Profile  
 
PostPosted: Thu Sep 13, 2007 12:09 pm 
Offline
Joined: Wed May 30, 2007 8:59 pm
Posts: 2
I had this same problem but I have found a simpler solution. Just rerun the initial pvr350 tvout script. It is under /usr/local/bin/setup_350.sh

You should be able to do this from a ssh connection. I used SecureCRT and I reran this script and rebooted This script rewrites the xorg.conf for the right configuration.

This easily works around the tvout failing on the first reboot problem.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 28, 2007 4:23 pm 
Offline
Joined: Thu Sep 27, 2007 9:06 pm
Posts: 3
Thanks for posting this. It saved my butt (my linux Kung Fu is weak). I've been using Myth 0.17 on FC3 since forever, never bothering to update 'cause it worked so well (well enough for me anyway) then suddenly zap2it is goes DOWN!...tried MythDora but couldn't get around the "Unable to initialize video", tried a fresh install of FC6 and following Mr. Wilson's Howto - no dice. KnoppMyth R5F27 did it ALL! No problems (except I switched hardware to get around the "Can't find KNOPPIX filesystem", boot:knoppmyth nodma and a plethora of other cheats didn't appear to help). Thanks, again!


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu