View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Tue Jan 06, 2004 11:14 pm 
Offline
Joined: Mon Jan 05, 2004 1:30 pm
Posts: 139
Location: New Hope, MN
Ok, Video off the second card is fuzzy at the moment, which is probably an artifact of the cable connection, but it's working as a dual input recorder.

Motherboard MSI KT4V K7 motherboard with a VIA (tm) KT400 chipset and a Athelon 1800 XP processor.
512 Meg 266 DDR memory
120 Gig 7200 rpm Seagate Hard Drive
2 Hauppauge! WinTV w dbx Stereo and FM Radio capture cards
1 SoundBlaster Live sound card.
Video card is a GeForce 2, 64Mb AGP 4x/2x "Mad Dog Champion" card
Current display is to a 19" Flat Panel LCD, or through a scan converter a 27" Toshiba TV, (display looks better on the LCD, larger and a bit washed out on the TV)
Sound is currently going to a JVC Tuner for home theater.


Modifications

/etc/modules

Code:
Original        Modified
rtc             rtc
apm power_off=1 apm power_off=1
usb-uhci        usb-uhci
serial          serial
emu10k1-gp      emu10k1-gp
                snd-emu10k1
                snd-mixer-oss
                btaudio
bttv            bttv
msp3400         msp3400
tvaudio         tvaudio
snd-emu10k1
snd-mixer-oss
tuner           tuner
via-rhine       via-rhine
agpgart         agpgart
af_packet       af_packet
autofs4         autofs4
ext3            ext3


The addition of btaudio was as per the notes in the link following the /etc/modutils/btaudio file. I order for btaudio to function as desired it needs to be before bttv. I ran into mythtv front end crashes until I realized that I needed the snd-emu10k1 and snd-mixer-oss files before it to greb the /dev/dsp0 file first. That gives me a dsp that mythtv can talk to. It's possible that I could have told it to use /dev/dsp3, however I think that would have been even more work.

Created a file /etc/modutils/btaudio
Code:
options bttv debug=2
options btaudio debug=2 digital=1 analog=0 rate=32000
pre-install btaudio modprobe snd-pcm-oss
post-install btaudio modprobe bttv
alias sound-slot-1 btaudio
alias sound-service-1-0 btaudio
alias sound-slot-2 btaudio
alias sound-service-2-0 btaudio

For an explanation of what these lines do see the URL:http://www.gossamer-threads.com/perl/mailarc/gforum.cgi?post=55962#55962 Thank you cesman for that link.

Then I ran update-modules to integrate the btaudio file into /etc/modules.conf This is slightly different from the suggestions in the link in that this is the prefered way to integrate updates to modules.conf

To use the black remote that comes with the model 401 Hauppauge! cards I ran irrecord and created a file hauppauge.black.conf containing the following:

Code:
# Please make this file available to others
# by sending it to <lirc@bartelmus.de>
#
# this config file was automatically generated
# using lirc-0.7.0pre2(hauppauge) on Tue Jan  6 13:56:58 2004
#
# contributed by
#
# brand:                       hauppauge.black.conf
# model no. of remote control:
# devices being controlled by this remote:
#
 
begin remote
 
  name  hauppauge.black.conf
  bits           13
  eps            30
  aeps          100
 
  one             0     0
  zero            0     0
  gap          199992
  min_repeat      4
  toggle_bit      0
 
 
      begin codes
          CH+                      0x0000000000001020
          CH-                      0x0000000000001021
          TV                       0x000000000000180F
          RADIO                    0x000000000000100C
          VOL+                     0x0000000000001010
          VOL-                     0x0000000000001011
          FULLSCREEN               0x000000000000102E
          MUTE                     0x000000000000180D
          SOURCE                   0x0000000000001822
          1                        0x0000000000001001
          2                        0x0000000000001802
          3                        0x0000000000001003
          4                        0x0000000000001804
          5                        0x0000000000001005
          6                        0x0000000000001806
          7                        0x0000000000001007
          8                        0x0000000000001808
          9                        0x0000000000001009
          0                        0x0000000000001800
          RESERVED                 0x000000000000101E
          MINIMIZE                 0x0000000000001826
      end codes
 
end remote
 


This I copied over /etc/lircd.conf

I then edited the file .mythtv/lircrc to look like:
Code:
# Hauppauge! Black Remote
begin
   prog = mythtv
   button = 1
   config = 1
end
 
begin
   prog = mythtv
   button = 2
   config = 2
end
 
begin
   prog = mythtv
   button = 3
   config = 3
end
 
begin
   prog = mythtv
   button = 4
   config = 4
end
.... (skiping the buttons 5-0)
begin
   prog = mythtv
   button = CH+
   repeat = 3
   config = Up
end
                                                                               
begin
   prog = mythtv
   button = CH-
   repeat = 3
   config = Down
end
 
begin
   prog = mythtv
   button = VOL+
   repeat = 3
   config = ]
end
                                                                               
begin
   prog = mythtv
   button = VOL-
   repeat = 3
   config = [
end
                                                                               
begin
   prog = mythtv
   button = MUTE
   config = F9
end
                                                                               
begin
   prog = mythtv
   button = SOURCE
   config = i
end
                                                                               
begin
   prog = mythtv
   button = FULLSCREEN
   config = w
end
                                                                               
begin
   prog = mythtv
   button = TV
   config = c
end
                                                                               
begin
   prog = mythtv
   button = RADIO
   config = Esc
end
                                                                               
begin
   prog = mythtv
   button = MINIMIZE
   config = m
end
                                                                               
begin
   prog = mythtv
   button = RESERVED
   config = Return
end


The only other changes that I had to make were pretty much all apt-get update; apt-get install xmltv, which brought in updates to a half dozen or so other things that are updated in Debian since the Knoppix build used for R4 was created.

All in all this is a working system. I have not installed mame, nor do I intend to. I just bought a PS/2 that I intend to play with in the future. I may make that into another Linux box, but it's not a high priority.

I will be happy to answer what questions I can.

-Rusty


Top
 Profile  
 
PostPosted: Sat Mar 22, 2008 6:59 pm 
Offline
Joined: Sat Mar 22, 2008 6:50 pm
Posts: 3
I have just bought a Hauppauge WinTV PVR 150 MCE Bundle and I have a hard time to set it up even if I just have used the remote files as you write.
I believe that it can be one of the existing configurations, probably a grey one, but I do not know how to restart the configuration without reinstalling the MythTV.

It shows a gray remote on the box but in reality its black.
Thank you!
Gabor

http://www.bestbuy.ca/catalog/proddetai ... atid=20397

:?


Top
 Profile  
 
PostPosted: Sun Mar 23, 2008 8:04 am 
Offline
Joined: Wed Nov 16, 2005 8:55 pm
Posts: 1381
Location: Farmington, MI USA
gorcsos wrote:
I have just bought a Hauppauge WinTV PVR 150 MCE Bundle and I have a hard time to set it up even if I just have used the remote files as you write.
Well, after 4 years I'm sure things have changed... :wink:

gorcsos wrote:
I believe that it can be one of the existing configurations, probably a grey one, but I do not know how to restart the configuration without reinstalling the MythTV.
I'm not sure which remote you need to select, but you can run /usr/local/bin/lirc-reconfig.sh.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu