View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Feb 11, 2006 4:42 pm 
Joined: Sun Feb 05, 2006 2:23 pm
Posts: 4
I've just installed on a machine with a Asus A8MX motherboard, with ATI graphics cards, a Lacie 250GB usb harddisk and a WinTV PVR250 card. I also have an Avermedia USB2 DVB box (the A800) which took a little tweak to get it to work.

Follow the instructions on this page to download the dvb-kernel modules from cvs and then copy the firmwares into /usr/lib/hotplug/firmware.

The modules are already there, so just unplugging the box and reconnecting it got it running.


 Post subject:
PostPosted: Mon Apr 10, 2006 10:34 am 
Joined: Mon Aug 29, 2005 11:29 am
Posts: 15
In earlier versions of KnoppMyth I also had to tweak the system to get Avernedia DVB-T USB 2.0 to work. But in the latest version R5B7 it worked out of the box. :D
However, the remote still was a problem. I finally got it working this way:
1) Remove the original lirc program(s): apt-get remove lirc
apt-get remove lirc-modules-source
And stop lirc from starting at bootup (I'll return to why): update-rc.d -f lirc remove
2) Download the latest lirc source ( as of now)
3) untar and compile: tar -xzvf lirc-0.8.0.tar gz; cd lirc-0.8.0
./configure --prefix=/usr --with-driver=devinput --with-x --sysconfdir=/etc/lirc
make && make install
4) You need new lircd.conf and hardware.conf (in /etc/lirc). I can mail them to anyone who needs them (lircd.conf is written by Thorster Maerz And /home/mythtv/.mythv/.lircrc needs to be changed. I can mail mine to anyone who wants to see my proposal.
5) This was the trickiest part. When I tried to start lirc from init.d it never found the correct /dev/input/event-number to connect to. Obviously the event-number was changed during booting (I guess anyway). This led to the syslog and daemon errorlogs to be written with thousands of error messages until the hard drive was full! So I had to write a modified /etc/init.d/lirc startscript that is called in /home/mythtv/.fluxbox/apps, using sudo - remember to modify /etc/sudoers and add /etc/init.d/lirc. This script finds the /dev/input/event-number dynamically by looking at /proc/bus/input/devices. I'll mail the script if needed.
So it was quit a way to wander to get the remote working, but finally!
Hopefully this can be of help to someone.
Greetings Göran

PostPosted: Sun Sep 24, 2006 4:32 am 
Joined: Sun Sep 24, 2006 3:56 am
Posts: 1
hello, could you select the a800 box directly in Mythtv as your device? If I try to select the devices my a800 box wont be shown in the list. The box was found during installation and the modules for the box are loaded too.
Any Ideas?


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu