View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 4 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Mar 18, 2006 8:46 am 
Joined: Mon Aug 29, 2005 4:04 pm
Posts: 729
Location: Philadelphia, PA US
R5A30.2 Auto Install
Install went fairly well. I have also had R5A16, R5A22, and R5A26 on this machine. All clean installs.

Hardware Specs:
Athlon XP1800
SOLTEK SL-75DRV5 Socket A (Socket 462) VIA KT333 ATX AMD Motherboard
Kingston ValueRAM 512MB 184-Pin DDR SDRAM DDR 266 (PC 2100)
Maxtor DiamondMax Plus 9 6Y080L0 80GB 7200 RPM IDE Ultra ATA133 Hard Drive
nVidia GeForce4 MX 440 AGP
Integraded VIA Technologies, AC97 Audio Controller
Generic 300w PS
Generic 3.5" diskette drive
Leadtek Winfast TV2000XP Deluxe tuner NTSC
Svideo TV output to Sony 27" Trinitron TV

The TV card is a VL4 software based card so quality isn't that great and recording size is large at 4GB an hour. Channels 2-6 are poorer quality than other channels with lines moving though picture. I switched connectors and cable same results. I plan to move the TV card as far away from video card and PS as possible as they may be interfering with signal. I have also messed with using MPEG4 recording profiles to reduce the recording to 1GB an hour.

Winfast TV200XP Deluxe Tuner ... V2000XPdlx
XTerm > mythtv-setup
Capture Card Standard VL4
pico /etc/modules (edited lines)
bttv card=34 tuner=2
tuner type=2

Remote Control for WinFast TV2000 Deluxe

cp --reply=yes /usr/local/share/knoppmyth/remotes/winfast_rm0010/etc/lircd.conf /etc/lircd.conf
cp --reply=yes /usr/local/share/knoppmyth/remotes/winfast_rm0010/etc/lircrc /home/mythtv/.mythtv/lircrc

dpkg-reconfigure lirc

Reconfigure for WinFast reciever

Setup VNC x11 Administration

apt-get install x11vnc

nano /etc/gdm/PreSession/Default

insert the following after the PATH line where xxxx is the desired password:
/usr/bin/x11vnc -nap -wait 50 -passwd xxxx -display :0 -forever -o /var/log/x11vnc.log -bg

Restart x-windows

Setup Webmin

/usr/share/webmin/ /etc/webmin root your_desired_password

nano /etc/webmin/miniserv.conf (edit line)
allow= XXX.XXX.XXX.0
/etc/init.d/webmin start
update-rc.d webmin defaults

Samba client and server setup ... SambaHowTo ... +and+samba

(Replaced variables)
/etc/init.d/samba start
update-rc.d samba defaults

echo �/mnt/network /etc/auto.samba.mnt --timeout=2 -�ghost� >>/etc/auto.master

echo �%servername-share% -fstype=smbfs,credentials=/home/mythtv/.smbpassword ://%windows-server-name%/%shared-folder-name%� >>/etc/auto.samba.mnt

echo username=%username% >> /home/mythtv/.smbpassword
echo password=%password% >> /home/mythtv/.smbpassword

/etc/init.d/autofs stop
/etc/init.d/autofs start

ln �s /myth/gallery/%servername-share% /mnt/network/%servername-share%/pics
ln �s /myth/music/%servername-share% /mnt/network/%servername-share%/audio
ln �s /myth/video/%servername-share% /mnt/network/%servername-share%/videos

#Add 2MB cache for Mplayer, assists in playing of network video files
echo cache=2048 >> /home/mythtv/.mplayer/config

XYAC client OSD CallerID

cd /home/mythtv
tar zxvf xyac*.tar*
cd xyac*
apt-get udpate
apt-get install libxosd2
apt-get install libxosd-dev
make install

pico /home/mythtv/.fluxbox/apps

below line �{xset...} line:� append�
[startup] {xyac -p middle -A center -c GRAY -s 1 -f lucidasanstypewriter-bold-24 &}


Setup XFE FileManager

apt-get udpate
apt-get install xfe
apt-get install nedit

pico /usr/share/mythtv/knoppmyth.xml


<text>File Manager</text>
<action>EXEC xfe</action>

Setup Time sync in Webmin
Set to sync with daily

Update Mplayer, Xvid, codecs, and Fonts
Download the following files from


download the latest xvid codec from
(xvidcore-1.1.0-final.tar.bz2 at the moment)

$ mkdir /usr/local/lib/codecs
$ tar -xjf each of the bz2 files
copy the contents of essential-20050412 to the codecs dir you just made
copy the font of your choice (24) to /usr/local/share/mplayer/font/

$ cd xvidcore/build/generic
$ ./configure
$ make
$ make install

$ cd Mplayer dir
$ ./configure --prefix=/usr
$ make
$ make install

Configure MythWifi ... light=wifi

wget ... fi.tar.bz2

tar -xjf mythwifi.tar.bz2

cd mythwifi

qmake && make && make install

cd ..


tar -xjf web.tar.bz2

cp -r web /var/www

cd /var/www/web

mkdir php_sessions;chmod a+rw php_sessions

cd layout


chmod 0777 /var/www/web/cache

Configure Channel Icons

perl /usr/bin/
(Respond to the prompts accordingly)

mythfilldatabase --import-icon-map iconmap.xml --update-icon-map

Optimize GUI settings and functions

Setup>Setup>TV Settings>Program Guide> Guide Shading Method>Blender � Transparent
Setup>Setup>General> System Exit key: Alt-ESC
Setup>Setup>General> Require Setup PIN, Setup PIN
Setup>Setup>Media Settings>Music Settings>Ripper Settings> Encoding MP3 Lame, Medium, Variable bitrates
Setup>Setup>Media Settings>Music Settings>General Settings> Ignore ID3 Tags, YES
Setup>Setup>Media Settings>Video Settings>General Settings> Show Unknown File Types, NO

Retro theme size adjustment
pico /usr/share/mythtv/themes/Retro/theme.xml

<background style="normal">

Last edited by spalVl on Mon Oct 08, 2007 7:01 pm, edited 4 times in total.

 Post subject:
PostPosted: Mon Oct 23, 2006 11:45 am 
Joined: Mon Aug 29, 2005 4:04 pm
Posts: 729
Location: Philadelphia, PA US
Walked the owner of this hardware though uprade from R5A30.2 to R5D1, went pretty smooth.

Had to replace the XF86Config-4 file with file backed up prior to upgrade


Winfast TV200XP Deluxe Tuner Instructions above worked

Setup VNC x11 Administration Instructions above worked

Didn't try the other above extra stuff as wasn't using often or in case of XFE has known issue with R5D1.

Was told by owner of this box that R5D1 gives better image quality than R5A30.2.

 Post subject:
PostPosted: Mon Oct 23, 2006 6:53 pm 
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
BTW - If you run into a problem with video playback, doublecheck the path to mplayer under the video setup screens. I discovered over the weekend that mine had a really old, and no longer correct, value...

 Post subject:
PostPosted: Mon Oct 08, 2007 6:58 pm 
Joined: Mon Aug 29, 2005 4:04 pm
Posts: 729
Location: Philadelphia, PA US
Owner was having problems with locking playing video from MythVideo. Walked though a fresh install of R5F27.

Overall went well, the Leadtek remote is no longer working but I think this is related to lirc_gpio bttv change in the kernel.

Plan on rerunning irrecord using /dev/input/event1 device. ... WithMythTV ... bug/125384

Will post full results when resolved.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu