View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 4 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Nov 09, 2008 12:10 pm 
Offline
Joined: Sat Jan 06, 2007 11:03 am
Posts: 11
I've been working on this for hours and was hoping someone could point me in the right direction to find a solution.

I have 2 systems, one master backend and one slave backend. The master backend is conneted to and LCD display running a resolution of 1920x1080. The slave backend is connected to an LCD display running at 1360x768. The master has 3 tuner cards, 1 WinTV-HVR-1250 for HD and 2 PVR-150's for SD. The slave has 1 PVR-150. I am able to watch all of the 150's from either system. The 1250 works fine on the master backend. The problem is, when I try to watch certian HD channels (CBS and NBC) from the 1250 on the slave backend, I just get a black screen and have to manually restart X to get out of it. This happens whether I watch these channels through live TV or recordings. Other HD channels work fine (ABC and Fox). I've looked through the mythbackend log and it looks like the channels that work are being recorded at 1280x720 and the ones that don't are recording at 1920x1088. I'm guessing that the problem has something to do with the slave backend's resolution being set to low to play the 1920x1088 content. Am I on the right track? If so, can anyone suggest a way that I could get all HD channels working on the slave? Is there something I could do on the slave to have it play the 1920x1088 content at a lower resolution (if that's the problem)? I would not be opposed to capturing the 1088 content at 720 on the master if that is possible. I can provide any logs or setting that anyone might need to help me out with this.

Thanks,

Ryan


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 09, 2008 12:20 pm 
Offline
Joined: Tue Jan 18, 2005 2:07 am
Posts: 1530
Location: California
The playback settings can be configured to be different based on the resolution of the recording being played. The difference in behavior could be a result of these rules. This gets discussed a bit in this thread. In that thread I suggested the following settings:

Quote:
In UTILS/SETUP->SETUP->TV Settings->Playback->Playback Profiles (screen 3), you need to create a new Video Playback Profile with the following 3 entries. In theory they can be created in any order, but as a precaution, please create them in the following order:

1. Match Criteria1 >= 1280 720, Match Criteria2 < 1920 1080, decoder=standard, MAX CPUs=2, video renderer=xv-blit, osd-renderer=softblend, osd fade=NOT checked, primary deinterlacer=None, Fallback deinterlacer=None. FYI -- these settings will be used to play back 720p recordings.

2. Match Criteria1 >= 1920 1080, Match Criteria2 = blank, decoder=standard, MAX CPUs=2, video renderer=xv-blit, osd-renderer=softblend, osd fade=NOT checked, primary deinterlacer=One Field, Fallback deinterlacer=None. FYI -- these settings will be used to play back 1080i recordings.

3. Match Criteria1 < 1280 720, Match Criteria2 = blank, decoder=standard, MAX CPUs=2, video renderer=xv-blit, osd-renderer=softblend, osd fade=checked, primary deinterlacer=bob2x, Fallback deinterlacer=One Field. FYI - these settings will be used to play back 480i recordings.

Please let me know how this works out. Some additional observations:


1. Your CPU is borderline for hidef playback. You will not have success without HT or XVMC. In this configuration, we are trying to use HT instead of XVMC. If that does not work, we will try XVMC.

2. One field is not a great deinterlacer, but it should give you reasonable results and is the least CPU intensive of all the choices.

3. In your initial experiments, please watch an already recorded show while you are not recording anything else. Do not attempt to watch live TV to gauge if this helps. If playback works by itself, you can then move on to seeing how it does when recording while playing back a show; then while watching live TV.

4. It would be useful if you remote logged into your myth box, ran "top -d 1" and reported back the % idle time available while doing playback.


Before you change to those settings, I suggest you check to see what settings you currently are using. I would also check the myth frontend log file to see if there are any telling entries -- its in /var/log/mythtv. I don't recall the exact filename, but
Code:
ls /var/log/mythtv/*front*.log
should find it for you.


Marc


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 09, 2008 3:08 pm 
Offline
Joined: Sat Jan 06, 2007 11:03 am
Posts: 11
Thanks Marc, the profile was set to CPU+. I created a new profile with the rules you suggested and now I am able to watch the recordings and live TV.

Thanks again for your help,

Ryan


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 09, 2008 7:11 pm 
Offline
Joined: Tue Jan 18, 2005 2:07 am
Posts: 1530
Location: California
Ryan, glad that worked. As I look at the original profile I posted, it was for a person that had a low-end processor. If your CPU is sufficiently fast, you will get higher quality playback by using the "bob2x" deinterlacer instead of "one field" for the 2nd and 3rd match criteria. Best bet is to set the "Primary deinterlacer" to bob2x and the "fallback deinterlacer" to "one field".

If you post your processor specs, I can give you a recommendation, or you can simply try it out to see how it works.

Marc


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu