View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 67 posts ] 
Go to page Previous  1, 2, 3, 4, 5  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri May 25, 2018 2:19 pm 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 398
Location: Charlotte, NC
Detected NVIDIA as the video card type
GeForce 9400 GT 0x0641 A

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
PostPosted: Fri May 25, 2018 2:40 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1120
Location: SC
The next line should tell what driver was installed. What was it?


Top
 Profile  
 
PostPosted: Fri May 25, 2018 4:54 pm 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 398
Location: Charlotte, NC
Detected NVIDIA as the video card type
GeForce 9400 GT 0x0641 A
Checking for nvidia-340xx in cache or online
Checking for nvidia-340xx-utils in cache or online
Checking for opencl-nvidia-340xx in cache or online
Checking for libglvnd in cache or online
Installing nvidia-340xx driver

Am running: VGA compatible controller: NVIDIA Corporation G96 [GeForce 9400 GT] (rev a1)
Driver: x86_64 Kernel Module 340.104 Thu Sep 14 17:13:13 PDT 2017
GCC version: gcc version 5.3.0

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
PostPosted: Mon May 28, 2018 4:37 pm 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 398
Location: Charlotte, NC
I tried a manual install of the nvidia drivers - see below

pacman -U nvidia-340xx-340.106-10-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "nvidia-340xx-utils=340.106", a dependency of "nvidia-340xx"
:: The following package cannot be upgraded due to unresolvable dependencies:
nvidia-340xx
This is on a fresh install of 8.5.1...

I removed 340.104 and installed 340.106 - rebooted - same errors "nvidia: disagrees about version of symbol module_layout"

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
PostPosted: Mon May 28, 2018 8:06 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1120
Location: SC
nbdwt73 wrote:
pacman -U nvidia-340xx-340.106-10-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "nvidia-340xx-utils=340.106", a dependency of "nvidia-340xx"
:: The following package cannot be upgraded due to unresolvable dependencies:
nvidia-340xx
This is on a fresh install of 8.5.1...
I would expect this. You need to manually install the .106 from testing of both the nvidia-340xx and nvidia-340xx-utils OR change your pacman.conf to point to the testing repos. But since the testing Nvidia driver is built against the newer kernel in testing you really should install that too. Change to the testing repos and pacman -Syyu.


Top
 Profile  
 
PostPosted: Tue May 29, 2018 10:58 am 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 398
Location: Charlotte, NC
Both nvidia-340xx and nvidia-340xx-utils were installed and I did a forced update (pacman -Syyu) (actually did the update first - no change - still showed nvidia 104 installed - and then I removed nvidia 104 and installed the nvidia 106 via pacman -U). I have also tried compiling manually from the nvidia site all with the same result. Obviously there is something in my box that this release doesn't like...

I havent yet tried replacing this card (9400 GT) with some other nvidia card (non series 9) and trying again. I think I have a card in my parts box... Given that this is a relatively common set of components and is a fresh install, it is important that I/we figure this out.

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
PostPosted: Wed May 30, 2018 4:50 pm 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 398
Location: Charlotte, NC
UPDATE - tried again - this time did a fresh install on a new HD; then without changing pacman.conf did a pacman -Syu (just for grins); then changed pacman.conf to testing; pacman -Syyu...

pacman -Syyu
:: Synchronizing package databases...
core-testing 227.5 KiB 1517K/s 00:00 [#######################################################] 100%
extra-testing 123.7 KiB 12.1M/s 00:00 [#######################################################] 100%
:: Starting full system upgrade...
:: Replace dirmngr with core-testing/gnupg? [Y/n] y
:: Replace dnsutils with extra-testing/bind-tools? [Y/n] y
:: Replace libcl with extra-testing/ocl-icd? [Y/n] y
:: Replace libdbus with core-testing/dbus? [Y/n] y
warning: perl-datetime-format-strptime: local (1.0900-1) is newer than core-testing (1.75-1)
:: Replace python-parted with core-testing/python2-pyparted? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: qt5-base and qtchooser are in conflict. Remove qtchooser? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: xmltv: requires perl-cgi
:: imagemagick: requires perl<5.17
:: archlinux-xdg-menu: installing perl-xml-parser (2.44-6) breaks dependency 'perlxml'
:: perl-xml-dom: installing perl-xml-parser (2.44-6) breaks dependency 'perlxml>=2.30'
:: perl-xml-xpath: installing perl-xml-parser (2.44-6) breaks dependency 'perlxml>=2.23'

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
PostPosted: Wed May 30, 2018 7:23 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1120
Location: SC
I am in the process of updating perl and looks like I accidently pushed it to testing. I will hopefully get it sorted tomorrow.


Top
 Profile  
 
PostPosted: Thu May 31, 2018 5:07 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1120
Location: SC
perl dep conflicts should be fixed.


Top
 Profile  
 
PostPosted: Thu May 31, 2018 6:16 pm 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 398
Location: Charlotte, NC
The great news is that 8.5.1 installs as expected on my box with the nvidia 9400GT. But when pacman -Syu from testing...

(364/364) checking for file conflicts [######################] 100%
error: failed to commit transaction (conflicting files)
perl-xml-sax: /usr/share/perl5/vendor_perl/XML/SAX/ParserDetails.ini exists in f ilesystem
Errors occurred, no packages were upgraded.

So - deleted ParserDetails.ini, reran and success... Will go back thru testing and let you know. So far, things look pretty good.

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
PostPosted: Thu May 31, 2018 6:29 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1120
Location: SC
So what changed on your box that now R8.5.1 install? Or did I misunderstand because I thought you said before it didn't?

Removing ParserDetails.ini is going to have to be a manual thing unfortunately. Or use the force option in pacman but I don't like that as general advice.


Top
 Profile  
 
PostPosted: Thu May 31, 2018 8:30 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 484
For the record, I am finally getting around to trying the testing repos again and I had the same error about the ParserDetails.ini file so I manually removed it as well. At least it does not actually start installing any of the packages until it is resolved. I will still have to recompile Kodi 18 before I start using the testing repos in earnest, but I am interested in re-testing the remote.


Top
 Profile  
 
PostPosted: Fri Jun 01, 2018 6:47 pm 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 398
Location: Charlotte, NC
Britney, you did not misunderstand... Has anything changed in the standard repos? When I install from the 8.5.1 DVD that I have (created last week) I have the nvidia error. As of 2 days ago when I pacman -Syu (standard repos) the nvidia error message is not present (before that time I still had the error). Nvidia version is 340.104

I now can change to the testing reops and update (couldnt before). Anyway, all testing so far looks good (except for that damn minor Plex issue... not ours). Nvidia version is now 340.106.

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
PostPosted: Fri Jun 01, 2018 7:30 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 484
FYI, I changed the behavior of the Harmony remote so that it is only sending the signal once instead of 3 times and that semi-corrected the LIRC issues in the testing repo without breaking them in the standard repo. It is detecting the press and hold much more quickly than the standard repo, but again, I think this is adjustable in the Harmony. I have not dug out the OEM streamzap remote to compare yet.

However, I am having an issue with compiling the Kodi 18 alpha 1 source. It gets to what appears to be the very end, and a very long instruction and spits out a bunch of errors related to /usr/bin/ld.gold. For example:
Code:
/usr/bin/ld.gold: error: /usr/local/lib/libfmt.a(format.cc.o): requires unsupported dynamic reloc 11; recompile with -fPIC

I "think" that I am still using the same PKGBUILD that I used before and I don't remember this type of error. I gather that ld.gold is part of the binutils package. Do you have any suggestions on correcting this? There are 20 lines like this followed by:
Code:
collect2: error: ld returned 1 exit status

and then other make error messages.


Top
 Profile  
 
PostPosted: Sat Jun 02, 2018 6:52 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1120
Location: SC
nbdwt73 wrote:
Has anything changed in the standard repos?
Last change to release repos was Feb 20.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 67 posts ] 
Go to page Previous  1, 2, 3, 4, 5  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu